4 Values whose Sum is 0 (二分+排序)

题面

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
 
 
题意:
给一个n*4的矩阵,输入n*4个数,在每一列找一个数,使得四个数的和为0;
 
分析:
先分别求出a和b,c和d两列任意两个数的和存放到相应的数组,将cd的和进行排序后,再用二分法进行查找;二分查找的时候注意,倘若中间的数据符合条件的话要再往两边进行查找,因为不能排除有多个数字相等的情况
 
注意:
求第二组数据的时候,根据提交的结果是不需要初始化total的;
题解:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N=4005;
int a[N],b[N],c[N],d[N];
int ab[N*N],cd[N*N];
int main()
{
   int n,total=0,i,j;
   while (cin>>n)
   {
         for (i=0;i<n;i++)
           cin>>a[i]>>b[i]>>c[i]>>d[i];
           int num1=0,num2=0;
         for (i=0;i<n;i++)
            for (j=0;j<n;j++)
           {
                ab[num1++]=a[i]+b[j];
                cd[num2++]=-(c[i]+d[j]);
           }
          sort (cd,cd+num2);
         for (i=0;i<num1;i++)
           {
              int mid,up=num2-1,low=0;
             while (low<=up)
             {
                mid=low+(up-low)/2;
               if (ab[i]==cd[mid])
                {
                  total++;
                    for (j=mid+1;j<=up;j++)
                  {

                       if (ab[i]==cd[j])
                          total++;
                       else
                           break;
                  }
                  for (j=mid-1;j>=low;j--)
                  {
                       if (ab[i]==cd[j])
                         total++;
                       else
                         break;
                  }


                  break;
              }
              else
              {
                  if (ab[i]>cd[mid])
                    low=mid+1;
                  else
                    up=mid-1;
              }
        }
    }
      cout << total << endl;
   }

        return 0;
}

转载自https://www.cnblogs.com/lisijie/p/7289457.html

posted @ 2020-04-06 12:32  XXXSANS  阅读(195)  评论(0编辑  收藏  举报