NEU 1497 Kid and Ants 思路 难度:0

问题 I: Kid and Ants

时间限制: 1 Sec  内存限制: 128 MB
提交: 42  解决: 33
[提交][状态][讨论版]

题目描述

Kid likes interest question,although he don’t like ants so much.

Assume there is a infinite long stick whose direction is from East to West. In addition, there are n

ants on the stick and their original orientation is arbitrary(East or West).Then from a moment,all

the ants will climb on the stick at the same speed toward their original orientation.Once two ants

touch each other, they will change their orientation and go up climbing.(May be some ants will

never meet other ants).So now Kid’s task is to calculate the mathematical expectation of the meets

between ants.

 

输入

There are multiple cases.

For each case,there is a integer n.(1<=n<=10^9)

 

输出

For each case,just print the mathematical expectation(retain three decimals)

 

样例输入

2
10

样例输出

0.250
11.250

提示

 

When n=2,there 4 cases(E indicates the orientation of the ant is East and W is West)


(left is East and right is West)


{E,E},{E,W},{W,E},{W,W}


And the number of meets is 0,0,1,0, so the mathematical expectation is (0+0+1+0)/4=0.250.

 

随便取两只蚂蚁,方案数n*(n-1)/2,对这两只蚂蚁有四种状态,一种碰撞
 
#include <cstdio>
using namespace std;
int main(){
    int n;
    while(scanf("%lf",&n)==1&&n){
        printf("%.3f\n",(double)n*(n-1)/8.0);          
    }
    return 0;
}

  

 
posted @ 2015-01-31 17:02  雪溯  阅读(147)  评论(0编辑  收藏  举报