poj 3348 Cows 凸包 求多边形面积 计算几何 难度:0 Source:CCC207

Cows
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7038   Accepted: 3242

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and yseparated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151
题意:题目的意思是给你n个点,让你用其中一些点围出最大面积,然后输出面积/50的下取整
思路:如果围出的多边形不是凸多边形,那么一定有凸多边形更优,所以求个凸包,计算凸包面积,/50取整
凸包算法:确定左下角的点,加入栈中,此后对于排过序的点,如果它到目前栈中最上面的两个点角度为钝角平角,那么它要比最上面那个点更优,弹出那个点,不断重复此操作,就能得到上凸包(因为点排过序,按照优先左的顺序,下凸包可能不完全),从第n-2点开始重复一遍此操作,得到下凸包
计算面积:左下角点一定是h[0],从左下角点连接所有到其他点的对角线,把原凸包分成很多个三角形,分别计算面积即可
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct pnt{
    int x,y;
    pnt(){x=y=0;}
    pnt(int tx,int ty){x=tx;y=ty;}
    pnt operator -(pnt p2){return pnt(x-p2.x,y-p2.y);}
    pnt operator +(pnt p2){return pnt(x+p2.x,y+p2.y);}
    bool operator <(pnt p2)const {if(x!=p2.x)return x<p2.x;return y<p2.y;}
    bool operator >(pnt p2)const {if(x!=p2.x)return x>p2.x;return y>p2.y;}
    bool operator ==(pnt p2)const {return x==p2.x&&y==p2.y;}
    int dot(pnt p2){return x*p2.x+y*p2.y;}//点积
    int det(pnt p2){return x*p2.y-y*p2.x;}//叉积
};
const int maxn=1e4+2;
pnt p[maxn],h[maxn];
int n,m;
void convexHull(){
    sort(p,p+n);
    m=0;
    for(int i=0;i<n;i++){//计算上凸包
        while(m>1&&(h[m-1]-h[m-2]).det(p[i]-h[m-2])<=0){m--;}
        h[m++]=p[i];
    }
    int tm=m;
    for(int i=n-2;i>=0;i--){//计算下凸包
        while(m>tm&&(h[m-1]-h[m-2]).det(p[i]-h[m-2])<=0){m--;}
        h[m++]=p[i];
    }
    if(n>1)m--;
}
double calArea(){
    double ans=0;
    for(int i=0;i<m;i++){
        ans+=(double)((h[i]-h[0]).det(h[(i+1)%m]-h[0]))/2;//使用叉积计算面积
    }
    return ans;
}
int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++)scanf("%d%d",&p[i].x,&p[i].y);
    convexHull();
    int ans=(int)(calArea()/50.0);
    printf("%d\n",ans);
    return 0;
}

  

posted @ 2014-11-29 02:37  雪溯  阅读(181)  评论(0编辑  收藏  举报