poj 3525 求凸包的最大内切圆

Most Distant Point from the Sea
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 3640   Accepted: 1683   Special Judge

Description

The main land of Japan called Honshu is an island surrounded by the sea. In such an island, it is natural to ask a question: “Where is the most distant point from the sea?” The answer to this question for Honshu was found in 1996. The most distant point is located in former Usuda Town, Nagano Prefecture, whose distance from the sea is 114.86 km.

In this problem, you are asked to write a program which, given a map of an island, finds the most distant point from the sea in the island, and reports its distance from the sea. In order to simplify the problem, we only consider maps representable by convex polygons.

Input

The input consists of multiple datasets. Each dataset represents a map of an island, which is a convex polygon. The format of a dataset is as follows.

n    
x1   y1
   
xn   yn

Every input item in a dataset is a non-negative integer. Two input items in a line are separated by a space.

n in the first line is the number of vertices of the polygon, satisfying 3 ≤ n ≤ 100. Subsequent n lines are the x- and y-coordinates of the n vertices. Line segments (xi, yi)–(xi+1, yi+1) (1 ≤ i  n − 1) and the line segment (xn,yn)–(x1, y1) form the border of the polygon in counterclockwise order. That is, these line segments see the inside of the polygon in the left of their directions. All coordinate values are between 0 and 10000, inclusive.

You can assume that the polygon is simple, that is, its border never crosses or touches itself. As stated above, the given polygon is always a convex one.

The last dataset is followed by a line containing a single zero.

Output

For each dataset in the input, one line containing the distance of the most distant point from the sea should be output. An output line should not contain extra characters such as spaces. The answer should not have an error greater than 0.00001 (10−5). You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied.

Sample Input

4
0 0
10000 0
10000 10000
0 10000
3
0 0
10000 0
7000 1000
6
0 40
100 20
250 40
250 70
100 90
0 70
3
0 0
10000 10000
5000 5001
0

Sample Output

5000.000000
494.233641
34.542948
0.353553

题目大意:求凸包的最大内切圆
分析:二分找答案,对凸包的每条边平移收缩,若半平面交不为空集,则可以存在此半径的圆。
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;

struct Point {
	double x, y;
	Point(double x=0, double y=0):x(x),y(y) { }
};

typedef Point Vector;

Vector operator + (const Vector& A, const Vector& B) { return Vector(A.x+B.x, A.y+B.y); }
Vector operator - (const Point& A, const Point& B) { return Vector(A.x-B.x, A.y-B.y); }
Vector operator * (const Vector& A, double p) { return Vector(A.x*p, A.y*p); }
double Dot(const Vector& A, const Vector& B) { return A.x*B.x + A.y*B.y; }
double Cross(const Vector& A, const Vector& B) { return A.x*B.y - A.y*B.x; }
double Length(const Vector& A) { return sqrt(Dot(A, A)); }
Vector Normal(const Vector& A) { double L = Length(A); return Vector(-A.y/L, A.x/L); }

double PolygonArea(vector<Point> p) {
	int n = p.size();
	double area = 0;
	for(int i = 1; i < n-1; i++)
		area += Cross(p[i]-p[0], p[i+1]-p[0]);
	return area/2;
}

// 有向直线。它的左边就是对应的半平面
struct Line {
	Point P;    // 直线上任意一点
	Vector v;   // 方向向量
	double ang; // 极角,即从x正半轴旋转到向量v所需要的角(弧度)
	Line() {}
	Line(Point P, Vector v):P(P),v(v){ ang = atan2(v.y, v.x); }
	bool operator < (const Line& L) const {
		return ang < L.ang;
	}
};

// 点p在有向直线L的左边(线上不算)
bool OnLeft(const Line& L, const Point& p) {
	return Cross(L.v, p-L.P) > 0;
}

// 二直线交点,假定交点惟一存在
Point GetLineIntersection(const Line& a, const Line& b) {
	Vector u = a.P-b.P;
	double t = Cross(b.v, u) / Cross(a.v, b.v);
	return a.P+a.v*t;
}

const double eps = 1e-6;

// 半平面交主过程
vector<Point> HalfplaneIntersection(vector<Line> L) {
	int n = L.size();
	sort(L.begin(), L.end()); // 按极角排序
	int first, last,i;         // 双端队列的第一个元素和最后一个元素的下标
	vector<Point> p(n);      // p[i]为q[i]和q[i+1]的交点
	vector<Line> q(n);       // 双端队列
	vector<Point> ans;       // 结果
	q[first=last=0] = L[0];  // 双端队列初始化为只有一个半平面L[0]
	for(i = 1; i < n; i++) {
		while(first < last && !OnLeft(L[i], p[last-1])) last--;
		while(first < last && !OnLeft(L[i], p[first])) first++;
		q[++last] = L[i];
		if(fabs(Cross(q[last].v, q[last-1].v)) < eps) { // 两向量平行且同向,取内侧的一个
			last--;
			if(OnLeft(q[last], L[i].P)) q[last] = L[i];
		}
		if(first < last) p[last-1] = GetLineIntersection(q[last-1], q[last]);
	}
	while(first < last && !OnLeft(q[first], p[last-1])) last--; // 删除无用平面
	if(last - first <= 1) return ans; // 空集
	p[last] = GetLineIntersection(q[last], q[first]); // 计算首尾两个半平面的交点
	// 从deque复制到输出中
	for(i = first; i <= last; i++) ans.push_back(p[i]);
	return ans;
}

int main() {
	int n;
	while(scanf("%d", &n) == 1 && n) 
	{
		vector<Vector> p, v, normal;
		int i, x, y;
		for(i = 0; i < n; i++) { scanf("%d%d", &x, &y); p.push_back(Point(x,y)); }
		for(i = 0; i < n; i++) {
			v.push_back(p[(i+1)%n]-p[i]);
			normal.push_back(Normal(v[i]));
		}
		
		double left = 0, right = 20000;
		while(right-left > 1e-6)
		{
			vector<Line> L;
			double mid = left+(right-left)/2;
			for(i = 0; i < n; i++) L.push_back(Line(p[i]+normal[i]*mid, v[i]));
			vector<Point> poly = HalfplaneIntersection(L);
			if(poly.empty()) right = mid; else left = mid;
		}
		printf("%.6lf\n", left);
	}
	return 0;
}

 

posted on 2013-11-18 20:59  雄..  阅读(748)  评论(0编辑  收藏  举报

导航