hdu 4722 数位dp

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 603    Accepted Submission(s): 221

Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number. You are required to count the number of good numbers in the range from A to B, inclusive.
 

 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases. Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).
 

 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

 

Sample Input
2
1 10
1 20
 
Sample Output
Case #1: 0
Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;

const int MAX=22;
__int64 dp[MAX][10];//分别代表长度为i位数和mod 10为j的个数 
int digit[MAX];

void digit_dp()
{//计算每长度为i为的数mod 10 == 0的个数 
    dp[0][0]=1;
    for(int i=1;i<MAX;++i)
    {
        for(int j=0;j<10;++j)
        {
            for(int k=0;k<10;++k)
            {
                dp[i][j]+=dp[i-1][(j-k+10)%10];
            }
        }
    }
}

__int64 calculate(__int64 n)
{
    int size=0,last=0;
    __int64 sum=0;
    while(n)
        digit[++size]=n%10,n/=10;
    for(int i=size;i>=1;--i)
    {
        for(int j=0;j<digit[i];++j)
        {
            sum+=dp[i-1][((0-j-last)%10+10)%10];
        }
        last=(last+digit[i])%10;
    }
    return sum;
}

int main()
{
    digit_dp();
    int t,num=0;
    __int64 a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&a,&b);
        printf("Case #%d: %I64d\n",++num,calculate(b+1)-calculate(a));
    }
    return 0;
}
View Code

 

 

 

 

posted on 2013-09-12 15:46  雄..  阅读(170)  评论(0编辑  收藏  举报

导航