ACM线性方程

Description

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 
 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 
 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input

77 51
10 44
34 79
 

Sample Output

2 -3
sorry
7 -3
 
解题思路:
题目大意是输入两个数字a,b 让我们求出满足方程X*a + Y*b = 1的x ,y如果没有找到就输出sorry,其中的x是非负的,y是一个整数。这个题目是其实是扩展欧几里德定理的模版题目,我们直接利用扩展欧几里德定理就可以解决。
程序代码:
#include <iostream>
#include <cstdio>
using namespace std;
//x*a+y*b=GCD(a,b)=GCD(b,a%b)=x*b+y*(a%b)=x*b+y*(a-a/b*b)=y*a+x*b-a/b*y*b=y*a+(x-a/b*y)*b
//即得到一次辗转相除后 x=y;y=x-a/b*y;
int extend_euclid(int a,int b,int &x,int &y)    //扩展欧几里德,能用64位尽量64位用32位可能超范围
{
    int res, tmp; 
    if (!b) 
	{
		x=1;
		y=0;
		return a;
	} 
    res = extend_euclid(b, a%b,x, y); 
    tmp = x-a/b*y;
	x = y;
	y = tmp;
    return res; 
}
int main()
{
    int a,b,x,y,z;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		z=extend_euclid(a,b,x,y);    //z即为a,b的最大公约数
	    if(z==1)
		{
		   while(x<0)
		   {
			   x=x+b/1;    //这里将x最小非负整数化(x可为0)
               y=y-a/1;    //运用a*x+b*y=1得到y
		   }
		   cout<<x<<" "<<y<<endl;
		}
	     else 
		    cout<<"sorry"<<endl;
	}
	return 0;
}

  

 
 
 
posted @ 2015-08-18 17:21  心向晴  阅读(296)  评论(0编辑  收藏  举报