本题要求实现二分查找算法。

函数接口定义:

 
Position BinarySearch( List L, ElementType X );
 

其中List结构定义如下:

 
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};
 

L是用户传入的一个线性表,其中ElementType元素可以通过>、==、<进行比较,并且题目保证传入的数据是递增有序的。函数BinarySearch要查找XData中的位置,即数组下标(注意:元素从下标1开始存储)。找到则返回下标,否则返回一个特殊的失败标记NotFound

裁判测试程序样例:

 
#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 10
#define NotFound 0
typedef int ElementType;

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List ReadInput(); /* 裁判实现,细节不表。元素从下标1开始存储 */
Position BinarySearch( List L, ElementType X );

int main()
{
    List L;
    ElementType X;
    Position P;

    L = ReadInput();
    scanf("%d", &X);
    P = BinarySearch( L, X );
    printf("%d\n", P);

    return 0;
}

/* 你的代码将被嵌在这里 */
 

输入样例1:

5
12 31 55 89 101
31
 

输出样例1:

2
 

输入样例2:

3
26 78 233
31
 

输出样例2:

0

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 10
#define NotFound 0
typedef int ElementType;

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List ReadInput(int X); /* 裁判实现,细节不表。元素从下标1开始存储 */
Position BinarySearch( List L, ElementType X );

int main()
{
    List L;
    ElementType X;
    Position P;
    int t;
    scanf("%d",&t);
    L = ReadInput(t);
    scanf("%d", &X);
    P = BinarySearch( L, X );
    printf("%d\n", P);

    return 0;
}

/* 你的代码将被嵌在这里 */
List ReadInput(int t){
    List L = (List)malloc(sizeof(struct LNode));
    ElementType *Data = (ElementType *)malloc(sizeof(ElementType) * MAXSIZE);
    ElementType a;
    for (int i = 1; i <= t; ++i) {
        scanf("%d",&a);
        L->Data[i] = a;
   //     printf("in\n");
    }
    L->Last = t;
 //   printf("%d\n",L->Last);
    return L;
}

Position BinarySearch( List L, ElementType X ){
    Position left = 1;
    Position right = L->Last;
    Position middle;
    while (left <= right) {
        middle = (left + right) / 2;
        if(L->Data[middle] < X){
            left = middle + 1;
        }else if(L->Data[middle] > X){
            right = middle - 1;
        }else{
            return middle;
        }
    }
    return NotFound;
}

 

posted on 2022-11-15 00:03  Rabbit_XIN  阅读(68)  评论(0编辑  收藏  举报