mysql数据库登录提示1053

创建mysql服务时,系统已提示创建服务成功,但是net start命令提示启动失败,并在services.msc中提示1053错误
 

操作系统:windows7 
mysql版本:5.5.22 
www.jb51.net 
在使用命令mysqld --install servicename --defaults-file='file_name'创建mysql服务时,系统 
已提示创建服务成功,但是net start命令提示启动失败,并在services.msc中提示1053错误

解决办法: 
在网上有人说是服务的“登录”选项卡里要设置成administrator; 
也有人说是需要先把服务删除,在重新创建(可以先考虑这两方面);

但是试过以后发现不起作用,经过检查才发现原来还是由mysqld --install命令引起的,主要原因 
在于--defaults-file所指向的路径不能在单引号,而是要在双引号之内 总之,把单引号替换为双引号,问题解决.

做个人职业站长真是不容易啊,看到服务有点卡了,重启下,没有想到MYSQL失效! 
MYSQL 1053错误 解决方法: 
在DOS命令行使用 
第一步: 
mysqld-nt remove mysqlservice 
的方式卸载此服务,它提示卸载成功,(是英文成功的意思) 
第二步: 
mysqld-nt install mysqlservice 
重新注册服务,一切恢复正常。 
(也会英文显示成功) 
第三步:
打开 服务>>>>禁用MYSQL>>>>再启动MYSQL 
就OK啦 

posted @ 2016-03-30 09:34  小猪爱夏  阅读(326)  评论(0)    收藏  举报