报错:ipython 6.5.0 has requirement prompt-toolkit<2.0.0,>=1.0.15, but you'll have prompt-toolkit 2.0.15 which is incompatible.

pip install imagededup 时,报错:ipython 6.5.0 has requirement prompt-toolkit<2.0.0,>=1.0.15, but you'll have prompt-toolkit 2.0.15 which is incompatible.

原因: setuptools 版本太高

解决方法:

conda install -c conda-forge prompt_toolkit==1.0.15

(上面1.0.15可改范围1.0.15 ~2.0.0(包含1.0.15)间任意版本)

posted @ 2019-10-10 10:47  小呆丶  阅读(2215)  评论(0编辑  收藏  举报