第十二周作业

这个作业属于那个课程| C语言程序设计II
---|:---😐---:
这个作业要求在哪里 |https://edu.cnblogs.com/campus/zswxy/computer-scienceclass4-2018/homework/3236
我在这个课程的目标是 |指针函数,链表
这个作业在那个具体方面帮助我实现目标 |了解指针函数,链表
参考文献 |c语言程序设计

6-1 计算最长的字符串长度

本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。

函数接口定义:

int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

4
blue
yellow
red
green

输出样例:

6

1.实验代码:

int max_len( char *s[], int n )
{
	int b[11];
	int i;
	int m=0;
	
    for(i=0; i<n; i++)
	{	
	
	  b[i]=strlen(s[i]);
      if(b[m]<b[i])
	  {
	 	b[m]=b[i];
	  }	
	 
	}
	
    return b[m];
 } 

3.错误:

遇到的问题:运行超时
解决方法:定义大一点的数组

4.运行截图:

6-2 统计专业人数

本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
    char code[8];
    struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。

函数接口定义:

int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:

3

1.实验代码:

int countcs( struct ListNode *head )
{
    struct ListNode s=*head;
    int SUM=0;
    for(s=head; s!=NULL; s=s->next){

        if(s->code[1] == '0' && s->code[2] == '2')
        {

        SUM++;
        }
    
    }
    return SUM;
}

3.错误:

遇到的问题:->使用错误。
解决方法:在看书和百度理解->的用法

4.运行截图:

6-3 删除单链表偶数节点

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链#表结点定义如下:

struct ListNode {
    int data;
    struct ListNode *next;
};

函数接口定义:

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 

代码



struct ListNode *createlist()

{

    int x;

    struct ListNode *head,*tail,*p;

    

    head=(struct ListNode*)malloc(sizeof(struct ListNode));

    head->next=NULL;

    tail=head;

    

    while(1)

    {

        p=(struct ListNode*)malloc(sizeof(struct ListNode));

        p->next=NULL;

        

        scanf("%d",&x);

        if(x==-1)

            break;

        p->data=x;

        p->next=NULL;

        

        tail->next=p;

        tail=p;

    }

    

    return head;

}

 

struct ListNode *deleteeven( struct ListNode *head )

{

    struct ListNode *p1,*p2;

    int flag;    

    p1=head;

    p2=p1->next;

    while(p1->next)

    {

        flag=0;

        if(p2->data%2==0)
        {

            p1->next=p2->next;

            p2=p2->next;

            flag=1;
        }

        if(flag==0)/

        {

            p1=p1->next;

            p2=p1->next;

        }

    }

    

    return head->next;

}


3.错误:

遇到的问题:对于链表结构的理解不够深刻,然后在使用的时候,就会出现各种各样的错误

4.运行截图:

心得

链表上课听了实在是没怎么听懂,都要自己百度看书,还是有很多不会,这周的题目做的我累死了,很是吃了

耗时:30小时

编程总结的感受

优点
结合两个人的思路能够更便捷的写出题目,并且发生错误的情况也会减少
缺点
多角度思考,难以统一思路

学习进度条

周/日期 这周所花的时间 代码行数 学到的知识点简介 目前比较迷惑问题
5/4-5/10 30h 400 指针函数 ,函数指针 链表

posted on 2019-05-19 15:03  q张信  阅读(106)  评论(0编辑  收藏  举报

导航