HDU4135

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2789    Accepted Submission(s): 1074

Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N. Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).
 

 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

 

Sample Input
2 1 10 2 3 15 5
 

 

Sample Output
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 
 
1.容斥初涉
2.找到交叉情况,即有条理的分析题目
#include<iostream>
#include<cstdio>
#include<string.h>
__int64 a[1200],num;
void gett(__int64 n)
{
    __int64 i;
    num=0;
    for(i=2;i*i<=n;i++)
      {
          if(n%i==0)
          {
              a[num++]=i;
              while(n%i==0)
                 n=n/i;
          }
      }
      if (n>1)
        a[num++]=n;
}
__int64 rc(__int64 m)
{
    __int64 q[10000],i,j,k,t=0,sum=0;
    q[t++]=-1;
    for(i=0;i<num;i++)
    {
        k=t;
        for(j=0;j<k;j++)
           q[t++]=q[j]*a[i]*(-1);
    }
    for(i=1;i<t;i++)
        sum=sum+m/q[i];
    return sum;
}
int main()
{
    __int64 T,x,y,n,sum;
    while (scanf("%I64d",&T)!=EOF)
    {
        for (int j=1;j<=T;j++)
        {
            scanf("%I64d %I64d %I64d",&x,&y,&n);
            gett(n);
            sum=y-rc(y)-(x-1-rc(x-1));
            printf("Case #%d: ",j);
            printf("%I64d\n",sum);
        }
    }
}
View Code

 

 
 
posted @ 2015-11-24 13:23  MC小肥仔  阅读(224)  评论(0编辑  收藏  举报