Android开发学习总结(三)——appcompat_v7项目说明

一、appcompat_v7项目说明

  今天来说一下appcompat_v7项目的问题,使用eclipse创建Android项目时,发现project列表中会多创建出一个appcompat_v7项目,这是我搭建最新的Android开发环境创建第一个Android测试项目后发现的,我在创建Android时选择的Minimum Required SDK是API:8 Android 2.2(Froyo),如下图所示:

  

  在这里解释一下这些名词:

  • SDK 是 Software Development Kit (软件开发工具包)的缩写。
  • Minimum Required SDK:最低支持SDK,一般默认的是8,即使应用根本不会在那么低的Android版本上运行;
  • Target SDK:目标SDK,即最高支持SDK,应用最佳运行的Android版本,不能低于Minimum Required SDK;
  • Compile With:编译的API(应用程序编译接口),即当前编译应用所用的API版本(也可以理解为SDK版本),一般默认与Target SDK相同,也可以高于Target SDK。

  结果创建完项目之后就多创建出一个appcompat_v7项目,如下图所示:

  

  appcompat_v7是作为一个类库项目存在的,本身不能单独运行,而HelloAndroid项目则引用了appcompat_v7项目,继而可以使用appcompat_v7编写好的类库,如下图所示:

  

  上网查了一下为什么会出现appcompat_v7这个项目,原来是:appcompat_v7是Google自己的一个兼容包,就是一个支持库,能让Android2.1以上全使用上4.0版本的界面。而刚才我们创建项目时,选择的能够运行HelloAndroid这个Android项目的最低Android版本(Minimum Required SDK)是API:8 Android 2.2(Froyo),所以Eclipse认为我们开发的应用要能够在Android2.2版本的系统上面运行,因此自动帮我们创建了appcompat_v7这个项目。appcompat_v7这个项目我们在开发中基本上不用理会的,专心在我们自己的项目上面做开发就好了。

二、创建项目避免创建appcompat_v7项目的办法

  在上面,我们已经知道了appcompat_v7这个项目为什么会被创建出来的原因,appcompat_v7是一个支持库,能让Android2.1以上全使用上4.0版本的界面。如果我们开发的应用不需要在Android4.0以下的平台运行,那么我们建项目时直接把最小SDK选在Android4.0以上,这样创建项目就可以避免多创建appcompat_v7这个项目,如下图所示:

  创建项目时选择Minimum Required SDK是API:15 Android 4.0.3,如下图所示: