D - Windows Message Queue

来源hdu1509

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

按价值排序,优先队列水题

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define scf(x) scanf("%d",&x)
#define scff(x,y) scanf("%d%d",&x,&y)
#define prf(x) printf("%d\n",x) 
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+7;
const double eps=1e-8;
const int inf=0x3f3f3f3f;
using namespace std;
const double pi=acos(-1.0);
const int N=3e2+10;
class mes
{
	public:
	char name[50];
	int cnt;
	int num,val;
	friend bool operator <(mes a,mes b)
	{
		if(a.val==b.val)
		return a.cnt>b.cnt;
		return a.val>b.val;
	}
};
priority_queue<mes> v;
void print(mes a)
{
	pf("%s %d\n",a.name,a.num);
}
int main()
{
	int cas=1;
	char a[5];
	while(~sf("%s",a))
	{
		if(a[0]=='G')
		{
			if(v.empty())
			pf("EMPTY QUEUE!\n");
			else
			{
				print(v.top());
				v.pop();
			}
			
		}else
		{
			mes t;
			t.cnt=cas++;
			sf("%s%d%d",t.name,&t.num,&t.val);
			v.push(t);
		}
	}
	return 0;
}
posted @ 2018-08-18 19:25  一无所知小白龙  阅读(214)  评论(0编辑  收藏  举报