HDU 1022 Train Problem I (数据结构 —— 栈)

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 


Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 


Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 


Sample Input
3 123 321 3 123 312
 


Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".


题意:给出初始序列和序列a和b。和一个栈c 。a仅仅能进c。不能回来。c仅仅能进b,求是否能达到目标并打印路径。

典型的栈,直接模拟。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <ctype.h>
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
int n ,op[4004];
char a[2005], b[2005], c[2005];
int main()
{
    while(~scanf("%d %s %s",&n,a,b)) {
        int i=0,j=0,top=-1,k=0;
        while(j<n) {  // b里还有车没匹配
            if( a[i] == b[j] ) { //a的第一辆与b直接匹配
                op[k++] = 1;
                op[k++] = 0;
                i++,j++;
            } else if( top >= 0 && c[top] == b[j]) { // 栈里的车与b匹配
                op[k++] = 0;
                j++,top--;
            } else if(i<n) {  // 都不匹配就把a里的车入栈
                top++;
                c[top] = a[i];
                op[k++] = 1;
                i++;
            } else break;  //a里没车了直接退出循环
        }
        if(j >= n) {
            printf("Yes.\n");
            for(int i=0;i<k;i++)
                if(op[i] == 1) printf("in\n");
                else printf("out\n");
        } else printf("No.\n");
        printf("FINISH\n");
    }
    return 0;
}



posted @ 2017-05-12 10:15  wzjhoutai  阅读(134)  评论(0编辑  收藏  举报