公司网络有代理的情况 yarn 配置代理访问网络

PS D:\MyProject> yarn
yarn install v1.17.3
[1/4] Resolving packages...
[2/4] Fetching packages...
error An unexpected error occurred: "https://registry.npm.taobao.org/clsx/download/clsx-1.0.4.tgz: getaddrinfo EAI_AGAIN registry.npm.taobao.org registry.npm.taobao.org:443".
info If you think this is a bug, please open a bug report with the information provided in "D:\\WAT-Frontend\\yarn-error.log".
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

PS D:\MyProject> yarn config get registry
https://registry.yarnpkg.com

PS D:\MyProject> yarn config set registry https://registry.npm.taobao.org
yarn config v1.17.3
success Set "registry" to "https://registry.npm.taobao.org".
Done in 0.04s.

PS D:\MyProject> yarn config get registry
https://registry.npm.taobao.org

PS D:\MyProject> yarn config set proxy http://username:password@192.168.71.230:8080
yarn config v1.17.3
success Set "proxy" to "http://username:password@192.168.71.230:8080".
Done in 0.04s.

PS D:\MyProject> yarn config set https-proxy http://username:password@192.168.71.230:8080
yarn config v1.17.3
success Set "https-proxy" to "http://username:password@192.168.71.230:8080".
Done in 0.04s.


PS D:\MyProject> yarn
yarn install v1.17.3
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@2.0.6: The platform "win32" is incompatible with this module.
info "fsevents@2.0.6" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@1.2.11: The platform "win32" is incompatible with this module.
info "fsevents@1.2.11" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > @material-ui/lab@4.0.0-alpha.27" has incorrect peer dependency "@material-ui/core@^4.4.0".
warning " > material-ui-dropzone@2.4.1" has unmet peer dependency "prop-types@^15.5.4".
warning "material-ui-dropzone > @material-ui/icons@3.0.2" has incorrect peer dependency "@material-ui/core@^3.0.0".
warning " > react-frame-component@4.1.0" has unmet peer dependency "prop-types@^15.5.9".
warning " > react-redux@7.1.0" has unmet peer dependency "redux@^2.0.0 || ^3.0.0 || ^4.0.0-0".
warning " > redux-devtools-extension@2.13.8" has unmet peer dependency "redux@^3.1.0 || ^4.0.0".
warning " > redux-persist@5.10.0" has unmet peer dependency "redux@>3.0.0".
warning " > eslint-plugin-react@7.14.3" has unmet peer dependency "eslint@^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0".
[4/4] Building fresh packages...
warning Your current version of Yarn is out of date. The latest version is "1.22.0", while you're on "1.17.3".
info To upgrade, download the latest installer at "https://yarnpkg.com/latest.msi".
Done in 1917.73s.

 

posted @ 2020-05-29 18:30  奥兰王子  阅读(...)  评论(...编辑  收藏