Description

Download as PDF

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where $2
\le N \le 79$. That is,


abcde / fghij =N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:


xxxxx / xxxxx =N

xxxxx / xxxxx =N

.

.


In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

Sample Input 

61
62
0

Sample Output 

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62

解题思路:
0~9十个数组成两个5位数(或0开头的四位数),要求两数之商等于输入的数据N。只要枚举fghjk就可以算出abcde,然后判断所有数字都不相同即可。

程序代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char s[50];
int main()
{
    int N,n=0;
    while(scanf("%d",&N)&&N)
    {   int f=0,fghjk;
        if(n++) printf("\n");
        for( fghjk= 1234; ;fghjk++)
        {
          int   abcde=fghjk*N;
        sprintf(s,"%05d%05d",abcde,fghjk);
        if(strlen(s)>10) break;
        sort(s,s+10);
        bool b=true;
        for(int i=0;i<10;i++)
            if(s[i]!=i+'0') b=false;

        if(b)
        {
            f++;
            printf("%05d / %05d = %d\n",abcde,fghjk,N);
        }

        }
        if(f==0)    printf("There are no solutions for %d.\n",N);
    }
    return 0;
}
View Code