ACboy needs your help again!

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 97 Accepted Submission(s): 77
 
Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 
Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 
Output

            For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
 
Sample Output
1
2
2
1
1
2
None
2
3
 
 
Source
2007省赛集训队练习赛(1)
 
Recommend
lcy
/*
题意:这个东西总共两种模式:栈和队列,然后模拟

解体思路:既然是模拟,就没什么搞得了。开搞

*/
#include<bits/stdc++.h>
using namespace std;
int t,n;
int a;
string op,name;
vector<int>v;
void init(){
    v.clear();
}
int main(){
    //freopen("in.txt","r",stdin);
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        cin>>name;
        init();
        if(name=="FIFO"){//先进先出
            for(int i=0;i<n;i++){
                cin>>op;
                if(op=="IN"){//进入
                    scanf("%d",&a);
                    v.push_back(a);
                }else{//
                    if(v.size()==0){
                        printf("None\n");
                    }else{
                        printf("%d\n",v[0]);
                        v.erase(v.begin());
                    }
                }
            }
        }else{//先进后出
            for(int i=0;i<n;i++){
                cin>>op;
                if(op=="IN"){//进入
                    scanf("%d",&a);
                    v.push_back(a);
                }else{//
                    if(v.size()==0){
                        printf("None\n");
                    }else{
                        printf("%d\n",v[v.size()-1]);
                        v.erase(v.end()-1);
                    }
                }
            }
        }
    }
    return 0;
}

 

posted @ 2017-02-03 18:12  勿忘初心0924  阅读(171)  评论(0编辑  收藏  举报