随笔分类 -  数据库相关

Ubuntu 16.04 设置MySQL远程访问权限
摘要:第一步:修改配置文件的端口绑定 打开的目录可能会根据MySQL的版本稍有不同,可以先尝试打开/etc/mysql/my.cnf这个配置文件,若该文件不存在或文件内容为空,则尝试下面的文件路径。 sudo vi /etc/mysql/mysql.conf.d/mysqld.cnf 在下面行的开头加上# 阅读全文

posted @ 2017-12-06 09:56 风林幻海 阅读(223) 评论(0) 推荐(0)

mysqldump备份还原和mysqldump导入导出语句大全详解(转)
摘要:转载:http://www.cnblogs.com/zeroone/archive/2010/05/11/1732834.html mysqldump备份: mysqldump -u用户名 -p密码 -h主机 数据库 a -w "sql条件" --lock-all-tables > 路径 案例: m 阅读全文

posted @ 2016-09-21 16:45 风林幻海 阅读(272) 评论(0) 推荐(0)

Mysql常用命令详解
摘要:转载:http://www.cnblogs.com/linjiqin/archive/2013/03/01/2939384.html Mysql安装目录(ubuntu系统)数据库目录/var/lib/mysql/配置文件/usr/share/mysql(mysql.server命令及配置文件)相关命 阅读全文

posted @ 2016-05-03 15:03 风林幻海 阅读(203) 评论(0) 推荐(0)

Ubuntu下的mysql安装
摘要:出处:http://blog.chinaunix.net/uid-26275986-id-4051976.html一、验证原有主机上是否安装mysql: 这里主要是运行sudo netstat -tap | grep mysql命令查看是否有Mysql的端口,如果不加sudo的话因为权限无法顺利执行... 阅读全文

posted @ 2015-02-06 10:26 风林幻海 阅读(165) 评论(0) 推荐(0)

Ubuntu下远程访问MySQL数据库
摘要:出处:http://www.2cto.com/database/201111/111309.htmlMySQL远程访问的命令格式:mysql -h 主机地址 -u 用户名 -p 用户密码示例:root@smt:~# mysql -h 10.0.1.191 -u root -p 123ERROR 20... 阅读全文

posted @ 2013-07-31 10:50 风林幻海 阅读(298) 评论(0) 推荐(0)

MySQL监控
摘要:check_mysql_health插件比起Nagios官方的check_mysql插件功能更为强大check_mysql_health不但能监控MySQL是否正常运行,还能监控MySQL主从、MySQL连接数情况、MySQL慢查询等多种监控指标。1)安装check_mysql_healthapt-... 阅读全文

posted @ 2013-07-30 16:27 风林幻海 阅读(627) 评论(0) 推荐(0)

Mysql源码安装
摘要:Mysql版本:mysql-5.5.25.tar.gz系统环境:Ubuntu11.04更新日期:2012年6月4日安装步骤(以下操作默认在root权限): tar mysql-5.2.5.25.tar.gz cd mysql-5.2.5.25 cmake -DCMAKE_INSTALL_PREFIX=/usr/local/mysql -DMYSQL_DATADIR=/mysql -DSYSCONFDIR=/etc -DWITH_INNOBASE_STORAGE_ENGINE=1 -DWITH_ARCHIVE_STORAGE_ENGINE=1 -DWITH_BLADKHOLE_STORAGE_E 阅读全文

posted @ 2013-05-31 18:01 风林幻海 阅读(150) 评论(0) 推荐(0)

SQL Error (1130): Host IP is not allowed to connect to this MySQL server
摘要:通过HeidiSQL连接MYSQL数据库报错:SQL Error (1130): Host '192.168.1.100' is not allowed to connect to this MySQL server说明所连接的用户帐号没有远程连接的权限,只能在本机(localhost)登录。需更改 mysql 数据库里的 user表里的 host项把localhost改称%首先按下面的步骤登录Mysql服务器登录mysql需要切换到dos下的mysql的bin目录,进行如下操作:mysql>use mysql;mysql>update user set host 阅读全文

posted @ 2013-05-31 16:21 风林幻海 阅读(216) 评论(0) 推荐(0)

Linux(ubuntu)下MySQL整个数据库的备份与还原 Linux下MySQL整个数据库的备份与还原[转]
摘要:Linux下MySQL整个数据库的备份与还原[root]# /usr/bin/mysqldump -h127.0.0.1 -uusername -ppassword databasename >/opt/share/1/backup.sql/usr/bin/mysqldump:用于执行的程序;-h:主机名称-u:数据库用户-p:数据库密码databasename:数据库名称>/opt/share/1/backup.sql:导出文件的保存名称以这样的方式导出的文件打开后发现里面有乱码,这个是正常的,是因为导出时没有设置字体的缘故,这个不影响数据库内容的备份和还原。然后使用[root] 阅读全文

posted @ 2012-10-18 11:11 风林幻海 阅读(397) 评论(0) 推荐(0)

解决ubuntu中mysql中文乱码问题
摘要:MySQL-5.5之前版本对字符编码方式修改的办法1.以root登陆,在终端输入命令 vi /etc/mysql/my.cnf在打开的文件中找到[client]在下面加入default-character-set=utf8 找到 [mysqld_safe]在下面加入default-character-set=utf8 找到[mysqld]在下面加入default-character-set=utf8 init_connect='SET NAMESutf8' 找到[mysql]在下面加入 default-character-set=utf82.重启mysql命令以便让上面的修改生 阅读全文

posted @ 2012-10-18 11:10 风林幻海 阅读(242) 评论(0) 推荐(0)

导航