hdu1161Eddy's mistakes

Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.
 
Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation composition, the writing length does not surpass 1000 characters.
 
Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 
Sample Input
weLcOmE tO HDOj Acm 2005!
 
Sample Output
welcome to hdoj acm 2005!
 
Author
eddy
 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

char s[1100];

int main()
{
    while(gets(s))
    {
        int i,j,k,l = strlen(s);
        for(i = 0;i<l;i++)
        {
            if(!(s[i]&(1<<5))) s[i]|=(1<<5);
        }
        puts(s);
    }
    return 0;
}

 

posted on 2015-06-16 20:24  wos1239  阅读(149)  评论(0编辑  收藏  举报

导航