POJ 2965 The Pilots Brothers' refrigerator 位运算枚举

 

 
The Pilots Brothers' refrigerator
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15176   Accepted: 5672   Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

 

受到POJ1753的启发,用枚举过了,但是这个题有高效的数学方法。。。

 

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;

struct node
{
    int data, step;
}path[65537];
queue<struct node>q;

int swit(int s, int n)
{
    int t = n / 4 * 4;
    for(int i = t; i <= t+3; i++)
        s ^= 1<<i;
    for(int i = n % 4; i < 16; i += 4)
        s ^= 1<<i;
    s ^= 1<<n;
    return s;
}

int vis[65537];
void bfs()
{
    while(!q.empty())
    {
        struct node u = q.front();
        q.pop();
        if(u.data == 0)
        {
            printf("%d\n", u.step);
            int tmp = u.data;
            for(int i = 0; i < u.step; i++)
            {
                printf("%d %d\n", 4-path[tmp].step/4, 4-path[tmp].step%4);
                tmp = path[tmp].data;
            }
            return;
        }
        for(int i = 0; i < 16; i++)
        {
            int y = swit(u.data, i);
            if(!vis[y])
            {
                q.push((struct node){y, u.step+1});
                path[y] = (struct node){u.data, i};
                vis[y] = 1;
            }
        }
    }
}

int main()
{
    char s[5];
    int x = 0;
    for(int i = 0; i < 4; i++)
    {
        scanf("%s", s);
        for(int j = 0; j < 4; j++)
        {
            if(s[j] == '+')
                x = (x<<1) + 1;
            else x <<= 1;
        }
    }
    memset(vis, 0, sizeof(vis));
    vis[x] = 1;
    q.push((struct node){x, 0});
    bfs();
    return 0;
}

 

posted @ 2013-06-22 16:36  Anti-Magic  阅读(191)  评论(0编辑  收藏  举报