hdu 1325判断是不是树

roblem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0

-1 -1

Sample Output

Yes
Yes
No

结束时两个小于零。。。还以为是两个-1。。
判断一个是不是树,先判断是不是连通,在判断是不是无回路。。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>

using namespace std;
const int maxn=100101;
int f[maxn],sign[maxn];
int flag;

int sf(int x){return x==f[x]?f[x]:f[x]=sf(f[x]);}

int U(int x,int y)
{
    x=sf(x),y=sf(y);
    if(x!=y)f[x]=y;
    else flag=0;//这是成环
}

int main()
{
    int n,m;
    int cnt=1;;
    while(cin>>n>>m)
    {
        if(n<=-1&&m<=-1)break;
        if(n==0&&m==0){printf("Case %d is a tree\n",cnt++);continue;}
        for(int i=1;i<maxn;i++)f[i]=i,sign[i]=0;
        sign[n]=sign[m]=1;
        flag=1;
        U(n,m);
        while(cin>>n>>m)
        {
            if(n==0&&m==0)break;
            sign[n]=sign[m]=1;
            U(n,m);
        }
        int ant=0;
        for(int i=1;i<maxn;i++){
            if(sign[i]&&f[i]==i)ant++;//记录有几个父节点,当大于时显然不是树
        }
        if(ant>1)flag=0;
        printf("Case %d ",cnt++);
        if(flag)printf("is a tree.\n");
        else printf("is not a tree.\n");
    }
}



posted @ 2016-05-05 12:48  adfae  阅读(112)  评论(0编辑  收藏  举报