tacker.conf参数解释
tacker.conf参数解释
本次修改FastDFS版本为v6.11.0
#配置tracker.conf这个配置文件是否生效,因为在启动fastdfs服务端进程时需要指定配置文件,所以需要使次配置文件生效。false是生效,true是屏蔽。
disabled = false
#绑定此主机的地址
#为空,用于绑定此主机的所有地址
#绑定IPv4示例:192.168.2.100
#绑定IPv6示例:2409:8a20:42d:2f40:587a:4c47:72c0:ad8e
#绑定IPv4和IPv6示例:192.168.2.100,2409:8a20:42d:2f40:587a:4c47:72c0:ad8e
#作为任何/所有地址,IPv4为0.0.0.0,IPv6为::
bind_addr =
#tracker监听的端口
port = 22122
#地址系列服务,价值列表:
##IPv4:IPv4堆栈
##IPv6:IPv6堆栈
##auto:当bind_addr为空时,通过bind_addl自动检测,先检测IPv4,然后检测IPv6
##both:IPv4和IPv6双堆栈
#以下参数use_storage_id必须设置为true,并且
#启用IPv6时,id_type_in_filename必须设置为id
#默认值为auto
#自V6.11起
address_family = auto
#连接超时(秒)
#默认值为30
#注意:在局域网(LAN)中,2秒钟就足够了。
#连接超时时间,针对socket套接字函数connect
connect_timeout = 5
#发送和接收的网络超时(以秒为单位)
#默认值为30
#tracker server的网络超时,单位为秒。发送或接收数据时,如果在超时时间后还不能发送或接收数据,则本次网络通信失败。
network_timeout = 60
#存储数据和日志文件的基本路径
# base_path 目录地址(根目录必须存在,子目录会自动创建)
base_path = /data/tracker
#此服务器支持的最大并发连接数
#你应该把这个参数设置得更大,例如10240
#默认值为256
max_connections = 10240
#接受线程数
#默认值为1,建议使用该值
#自V4.07起
#该参数决定接收客户端连接的线程数,默认值为1,适当放大该参数可改善Storage处理连接的能力,改成2[线上环境cpu为32核心可支持足够多的线程数]。
accept_threads = 1
#工作线程数
#处理网络io的工作线程
#默认值为4
#自 V2.00版起
#工作线程用来处理网络IO,默认值为4,该参数影响Stroage可以同时处理的连接数
work_threads = 4
#最小网络buff大小
#默认值8KB
#接收/发送数据的buff大小,必须大于8KB
min_buff_size = 8KB
#最大网络buff大小
#默认值128KB
#接收/发送数据的buff大小必须小于128KB
max_buff_size = 128KB
#选择上传文件组的方法
#0:循环
#1:指定组
#2:负载平衡,选择最大可用空间组上传文件
store_lookup = 0
#要上载文件的组
#当store_lookup设置为1时,必须将store_group设置为组名称
store_group = group2
#要上传文件的存储服务器
#0:循环(默认)
#1:按ip地址排序的第一个服务器订单
#2:按优先级排列的第一个服务器顺序(最小)
#注意:如果use_trunk_file设置为true,则必须将store_server设置为1或2
#在group中的哪台storage做主storage,当一个文件上传到主storage后,就由这台机器同步文件到group内的其他storage上,0:轮训策略 1:根据ip地址排序,第一个 2:根据优先级排序,第一个
store_server = 0
#要上载文件的存储服务器的路径(指磁盘或挂载点)
#0:循环
#2:负载平衡,选择上传文件的最大可用空间路径
#选择文件上传到storage中的哪个(目录/挂载点),storage可以有多个存放文件的base path 0:轮训策略 2:负载均衡,选择空闲空间最大的
store_path = 0
#要下载文件的存储服务器
#0:循环(默认)
#1:当前文件上传到的源存储服务器
#选择那个storage作为主下载服务器,0:轮训策略 1:主上传storage作为主下载服务器
download_server = 0
#为系统或其他应用程序保留的存储空间。
#如果中任何大型服务器的可用空间
#一个组<=reserved_storage_space,没有文件可以上传到此组。
#字节单位可以是以下之一:
###G或G表示GB
###M或M表示兆字节(MB)
###K或K表示千字节(KB)
###字节(B)无单位
#
###XX。XX%作为比率,例如:reserved_storage_space=10%
#
#注意:
##绝对保留空间是存储服务器中所有存储路径的总和
##保留空间比率适用于每个存储路径
#系统预留空间,当一个group中的任何storage的剩余空间小于定义的值,整个group就不能上传文件了
reserved_storage_space = 20%
#标准日志级别为syslog,不区分大小写,值列表:
### emerg for emergency
### alert
### crit for critical
### error
### warn for warning
### notice
### info
### debug
#日志信息级别
log_level = info
#运行该程序的unix组名称,
#未设置(空)表示由当前用户组运行
#进程以那个用户/用户组运行,不指定默认是当前用户
run_by_group=
run_by_user =
#allow_hosts可以存在多次,host可以是hostname或ip地址,
#“*”(只有一个星号)表示匹配所有ip地址
#我们可以使用CIDR ips,如192.168.5.64/26
#也可以使用这样的范围:10.0.1.[0-254]和host[01-08,20-25].domain.com
# allow_hosts=10.0.1.[1-15,20]
# allow_hosts=host[01-08,20-25].domain.com
# allow_hosts=192.168.5.64/26
#允许那些机器连接tracker默认是所有机器
allow_hosts = *
#每隔几秒将日志缓冲同步到磁盘
#默认值为10秒
#刷新日志信息到disk的间隔
sync_log_buff_interval = 10
#检查存储服务器的活动间隔秒
#检测 storage server 存活的时间隔,单位为秒。
#storage server定期向tracker server 发心跳,如果tracker server在一个check_active_interval内还没有收到storage server的一次心跳,那边将认为该storage server已经下线。所以本参数值必须大于storage server配置的心跳时间间隔。通常配置为storage server心跳时间间隔的2倍或3倍。
check_active_interval = 120
#线程堆栈大小,应>=64KB
#默认值为256KB
#线程栈的大小。FastDFS server端采用了线程方式。更正一下,tracker server线程栈不应小于64KB,不是512KB。
thread_stack_size = 256KB
#存储服务器的ip地址更改时自动调整
#默认值为true
#storage的ip改变后服务端是否自动调整,storage进程重启时才自动调整
storage_ip_changed_auto_adjust = true
#存储同步文件最大延迟秒数
#默认值为86400秒(一天)
#自V2.00版起
#storage之间同步文件的最大延迟,默认1天
storage_sync_file_max_delay = 86400
#存储同步文件的最长时间
#默认值为300秒
#自V2.00版起
#存储服务器同步一个文件需要消耗的最大时间,单位为300s,即5分钟。
storage_sync_file_max_time = 300
#是否使用小文件合并存储特性 [false代表关闭]
use_trunk_file = false
#最小插槽大小,应<=4KB
#默认值为256字节
#自V3.00起
#trunk file分配的最小字节数。比如文件只有16个字节,系统也会分配slot_min_size个字节。
slot_min_size = 256
#最大插槽大小,应>slot_min_size
#当上传文件的大小<=此值时,将其存储到trunk文件
#默认值为16MB
#自V3.00起
#只有文件大小<=这个参数值的文件,才会合并存储。如果一个文件的大小大于这个参数值,将直接保存到一个文件中(即不采用合并存储方式)
slot_max_size = 1MB
#分配主干空间的对齐大小
#默认值为0(从不对齐)
#自V6.05起
#注:对齐大小越大,磁盘出现的可能性越小
#碎片化,但浪费的空间越多。
#对齐大小越大,磁盘碎片的可能性越小,但浪费的空间也更多。
trunk_alloc_alignment_size = 256
#是否合并中继文件的连续可用空间
#默认值为false
#自V6.05起
#是否合并中继文件的连续可用空间
trunk_free_space_merge = true
#是否删除/回收未使用的中继文件
#默认值为false
#自V6.05起
#files 删除/回收未使用的中继文件
delete_unused_trunk_files = false
#中继文件大小,应>=4MB
#默认值为64MB
#自V3.00起
#trunk file 大小
trunk_file_size = 64MB
#是否提前创建 trunk file
trunk_create_file_advance = false
#创建中继文件的时间基础
#时间格式:HH:MM
#默认值为02:00
#自V3.06起
#提前创建trunk file的起始时间点(基准时间),02:00表示第一次创建的时间点是凌晨2点。
trunk_create_file_time_base = 02:00
#创建 trunk file 时间间隔, 86400 即隔一天
trunk_create_file_interval = 86400
#创建中继文件的阈值
#当空闲中继文件大小小于阈值时,
#将创建中继文件
#默认值为0
#自V3.06起
#提前创建trunk file时,需要达到的空闲trunk大小
#比如本参数为20G,而当前空闲trunk为4GB,那么只需要创建16GB的trunk file即可。
trunk_create_file_space_threshold = 20G
#trunk初始化时,是否检查可用空间是否被占用
trunk_init_check_occupying = false
#如果忽略storage_trunk.dat,则从trunk binlog重新加载
#默认值为false
#自V3.10起
#当您的版本低于V3.10时,为版本升级设置一次true
#是否无条件从trunk binlog中加载trunk可用空间信息
#FastDFS缺省是从快照文件storage_trunk.dat中加载trunk可用空间,
#该文件的第一行记录的是trunk binlog的offset,然后从binlog的offset开始加载
trunk_init_reload_from_binlog = false
trunk_compress_binlog_min_interval = 86400
#压缩 trunk binlog 文件的最小间隔
#压缩trunk binlog文件的最小间隔
#单位:秒,0表示从不压缩
#FastDFS在trunk init和trunk destroy时压缩trunk binlog
#建议将此参数设置为86400(一天)
#默认值为0
#自V5.01起
#压缩 trunk binlog 文件的间隔时间 (默认1天)
trunk_compress_binlog_interval = 86400
#压缩trunk binlog时基,时间格式:小时:分钟
#0到23的小时,0到59的分钟
#默认值为03:00
#自V6.05起
#压缩 trunk binlog 文件的时间点
trunk_compress_binlog_time_base = 03:00
#trunk binlog 文件最大备份数
trunk_binlog_max_backups = 7
#是否使用server ID作为storage server标识
use_storage_id = false
#use_storage_id 设置为true,才需要设置本参数
#在文件中设置组名、server ID和对应的IP地址,参见源码目录下的配置示例:conf/storage_ids.conf
storage_ids_filename = storage_ids.conf
#文件名中存储服务器的id类型,值为:
##ip:存储服务器的ip地址
##id:存储服务器的服务器id
#只有当use_storage_id设置为true时,此参数才有效
#默认值为ip
#自V4.03起
#存储服务ID文件中的 ID 类型
id_type_in_filename = id
#如果信任存储服务器发送的存储服务器ID
#只有当use_storage_id设置为true时,此参数才有效
#默认值为true
#自V6.11起
trust_storage_server_id = true
#如果存储从属文件使用符号链接
#默认值为false
#自V4.01起
#存储从文件是否使用符号链接
store_slave_file_use_link = false
#如果每天轮换错误日志
#默认值为false
#自V4.02起
#是否定期轮转error log,目前仅支持一天轮转一次
rotate_error_log = false
#旋转错误日志时基,时间格式:小时:分钟
#0到23的小时,0到59的分钟
#默认值为00:00
#自V4.02起
#error log定期轮转的时间点,只有当rotate_error_log设置为true时有效
error_log_rotate_time = 00:00
#是否用gzip压缩旧的错误日志
#默认值为false
#自V6.04起
#是否压缩旧的错误日志
compress_old_error_log = false
#压缩它几天前的错误日志 (compress_old_error_log = false本参数不生效)
compress_error_log_days_before = 7
#当日志文件超过此大小时轮转错误日志
#0表示从不按日志文件大小轮转日志文件
#默认值为0
#自V4.02起
#error log按大小轮转
#设置为0表示不按文件大小轮转,否则当error log达到该大小,就会轮转到新文件中
rotate_error_log_size = 0
#日志文件保留几天(0代表永久保留)
log_file_keep_days = 0
#是否使用连接池
#默认值为false
#自V4.05起
#是否使用连接池
use_connection_pool = true
#空闲时间超过此时间的连接将被关闭
#单位:秒
#默认值为3600
#自V4.05起
#连接空闲时长,超过则连接被关闭 (单位秒)
connection_pool_max_idle_time = 3600
#此跟踪器服务器上的HTTP端口
http.server_port = 8080
#检查storage HTTP服务器的活动间隔秒
#<=0表示从不检查
#默认值为30
http.check_alive_interval = 30
#检查storage HTTP服务器活动类型,值为:
#tcp:仅使用HTTP端口连接到存储服务器,
#不要请求并得到响应
#http:storage check alive url必须返回http状态200
#默认值为tcp
http.check_alive_type = tcp
#检查 storage HTTP服务器的活动uri/url
#注意:存储嵌入HTTP服务器支持uri:/status.html
http.check_alive_uri = /status.html
# 附目录说明:
tracker server目录及文件结构:
${base_path}
|__data
| |__storage_groups_new.dat:存储分组信息
| |__storage_servers_new.dat:存储服务器列表
|__logs
|__trackerd.log:tracker server日志文件
数据文件storage_groups.dat和storage_servers.dat中的记录之间以换行符(\n)分隔,字段之间以西文逗号(,)分隔。
storage_groups.dat中的字段依次为:
1. group_name:组名
2. storage_port:storage server端口号
storage_servers.dat中记录storage server相关信息,字段依次为:
1. group_name:所属组名
2. ip_addr:ip地址
3. status:状态
4. sync_src_ip_addr:向该storage server同步已有数据文件的源服务器
5. sync_until_timestamp:同步已有数据文件的截至时间(UNIX时间戳)
6. stat.total_upload_count:上传文件次数
7. stat.success_upload_count:成功上传文件次数
8. stat.total_set_meta_count:更改meta data次数
9. stat.success_set_meta_count:成功更改meta data次数
10. stat.total_delete_count:删除文件次数
11. stat.success_delete_count:成功删除文件次数
12. stat.total_download_count:下载文件次数
13. stat.success_download_count:成功下载文件次数
14. stat.total_get_meta_count:获取meta data次数
15. stat.success_get_meta_count:成功获取meta data次数
16. stat.last_source_update:最近一次源头更新时间(更新操作来自客户端)
17. stat.last_sync_update:最近一次同步更新时间(更新操作来自其他storage server的同步)

浙公网安备 33010602011771号