PAT 1006 Sign In and Sign Out 查找元素

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133
 
题目意思:第一个进机房的人开锁,最后一个出机房的人上锁关门,给出每个人的ID和进机房出机房的时间,找出开锁和上锁人的ID。
解题思路:由于时间采用的是24h制,所以在同一的格式下,将时间全都转换为秒数是最方便的,之后便利比较,找出最大和最小时间即可。
#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
using namespace std;
int main()
{
    int k,h,m,s;
    int i,in_time,out_time;
    int maxs=0,mins=0x7fffffff;
    string str,unlock,lock;
    cin>>k;
    for(i=0; i<k; i++)
    {
        cin>>str;
        scanf("%d:%d:%d",&h,&m,&s);
        in_time=h*3600+m*60+s;
        scanf("%d:%d:%d",&h,&m,&s);
        out_time=h*3600+m*60+s;
        if(in_time<mins)
        {
            mins=in_time;
            unlock=str;
        }
        if(out_time>maxs)
        {
            maxs=out_time;
            lock=str;
        }
    }
    cout<<unlock<<" "<<lock;
    return 0;
}

 

posted @ 2019-08-11 18:50  王陸  阅读(297)  评论(0编辑  收藏  举报