ERROR: for *** Cannot start service portal: endpoint with name harbor-portal already exists in network harbor_harbor

问题:harbor-harbor网桥无法停止

出现该问题,首先执行如下命令:

docker-compose down

使用docker network list查看该网桥

此时使用docker network rm无法移除该网桥

需要docker network inspect 查看该网桥连接的容器,然后disconnect该容器,就可以rm网桥

disconnect容器,然后再移除网桥,就不会再报错

然后,重启harbor,服务恢复正常

posted @ 2020-08-11 16:28  莹火  阅读(566)  评论(0)    收藏  举报