智能路由器-OpenWRT 系列二 (OpenWRT初始配置)

OpenWRT 初始化配置

OpenWRT刷机成功后,下面需要做的就是配置路由器连接网络。从OpenWRT官网下载的标准固件,一般是不含有Web管理页面的(一般路由器如TP-Link、Netgear都会有web管理页面),同时WIFI是没有开启的,OpenWRT内网IP默认设置为192.168.1.1 。

登录路由器

所以需要通过命令行登陆到路由器中。第一次要通过telnet进入路由器,ssh是无法登录的,因为未设置OpenWRT的root密码。

Linux、Mac 系统直接使用Terminal(终端),Windows 系统则通过 【开始】-【运行】- 输入【cmd】打开命令提示符。

首先将电脑通过有线和路由器连接,并设置有线网络的IP为 192.168.1.xxx, 网关设置为 192.168.1.1

输入命令: telnet 
出现提示符 'telnet>' 
输入 open 192.168.1.1 23

会出现如下界面:

telnet> open 192.168.1.1 23
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.23.2 (2016-01-02 10:46:55 CET) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (15.05.1, r48532)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# 

配置root密码

登录路由器后,就可以设置root的密码。密码设置后既可以通过ssh登录到路由器。ssh更安全且更方便使用。

在提示符后输入命令 passwd

root@OpenWrt:/# passwd     #输入命令passwd
Changing password for root
New password:            #输入密码 
Retype password:              #确认密码 
Password for root changed by root  #密码修改成功
root@OpenWrt:/#

配置网络连接

网络配置是通过 UCI 文件 '/etc/config/network' 配置的。我们可以直接手动编辑该文件,也可以通过uci 命令行。 (UCI:Unified Configuration Interface 统一配置接口的缩写)

uci命令配置通过猫的拨号连接上网:

# Configure pppoe connection
uci set network.wan.proto=pppoe
uci set network.wan.username='上网拨号账号'
uci set network.wan.password='上网密码'
# Save changes 保存更改
uci commit network

配置完毕后通过如下命令,重启网络服务,使设置生效:

/etc/init.d/network restart

打开你的浏览器,看下网络是否通了。

或者用ping 命令看下网络是否畅通,如下所示则拨号成功。

# ping baidu.com
PING baidu.com (111.13.101.208): 56 data bytes
64 bytes from 111.13.101.208: seq=0 ttl=51 time=26.808 ms
64 bytes from 111.13.101.208: seq=1 ttl=51 time=27.550 ms
64 bytes from 111.13.101.208: seq=2 ttl=51 time=26.652 ms
64 bytes from 111.13.101.208: seq=3 ttl=51 time=27.135 ms

直接修改network配置文件连接上网:

通过文本编辑器vi打开配置文件:

vi vi /etc/config/network

同时按下G+Shift键,移动至文件末尾 按下o键,输入如下内容:

config interface 'wan'                    
        option ifname 'eth0.2'            
        option proto 'pppoe'              
        option username '上网拨号账户'     
        option password '上网拨号密码'          
  

按下ESC键, 输入

:wq 

退出编辑后,重启网络服务

/etc/init.d/network restart

按照如上步骤检查网络是否畅通。

配置WIFI无线网络

和有限网络的配置一样,wifi的配置文件也位于/etc/config文件夹中,配置文件为/etc/config/wireless, 也可以通过直接编辑该文件或者通过uci命令进行设置。 但是最简单的方式是使用‘ wifi detect ’命令自动检测生成配置文件:

登录路由器后输入如下命令:

root@OpenWrt:~# rm -f /etc/config/wireless; wifi detect > /etc/config/wireless

如作者的输出如下:

config wifi-device  radio0
    option type     mac80211
    option channel  11
    option hwmode   11g
    option path 'platform/ar934x_wmac'
    option htmode   HT20
    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled 1

config wifi-iface
    option device   radio0
    option network  lan
    option mode     ap
    option ssid     OpenWrt
    option encryption none

config wifi-device  radio1
    option type     mac80211
    option channel  36
    option hwmode   11a
    option path 'pci0000:00/0000:00:00.0'
    option htmode   HT20
    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled 1

config wifi-iface
    option device   radio1
    option network  lan
    option mode     ap
    option ssid     OpenWrt
    option encryption none

启用/重启/关闭 无线接口

在 Openwrt下要 启用/重启/关闭 无线接口是使用命令 "wifi"来完成的。

启动无线接口:不带参数直接在命令行运行 wifi 命令;

如果修改了无线的配置,我们需要重新启动无线接口使配置生效,同样是不带参数直接在命令行下运行 wifi 命令;

如果需要关闭无线装置,加上" down "参数使用 "wifi down"

大多数情况下新安装的 Openwrt 是默认关闭无线接口的。

wifi   #开启wifi
wifi down #关闭wifi

打开笔记本或者手机,搜索一下无线网络,看看是不是出现了新的名称为‘OpenWrt’的网络信号。如果出现了,连上试试吧。

注意:此时的无线信号是没有加密的,了解无线配置的基本说明后,我们继续配置网络的密码。

一个典型的无线设置文件至少应该包含两个方面的内容,即至少一个无线设备 和 至少一个与之相关的无线接口 配置。

无线设备 的设置指的是一般无线电通讯相关的参数,例如设备硬件(网卡芯片驱动程序类型),信道,频率,发射功率等;

无线接口 的设置指的是 无线设备 的工作模式,essid,无线加密方式等。

无线设备 和 无线接口 具有关联性,首先是设置好一个 无线设备 的参数,然后再设置与这个 无线设备 相关的 无线接口 参数,从而构造出一个可以有效工作的无线局域网环境。

wifi-device 配置项

wifi-device 所配置的是指设备中无线通讯硬件,很多情况中,一个设备只有一个无线通讯接口,所以只有一个 wifi-device 配置项,如果有多个无线通讯设备则会有多个 wifi-device 配置项,每个配置项用来指定不同的接口。

一个最小的 wifi-device 配置就像下面的例子,需要注意的是其中所指定的不同的芯片类型和驱动。

config 'wifi-device' 'wl0'
        option 'type'    'broadcom'
        option 'channel' '6'
        
wl0        是无线网卡的内置标识符
broadcom   表示芯片或驱动程序的类型
6          指定无线网卡工作的无线频道

简单介绍配置的常见选项,对比看下wifi detect的输出:

名称 类型 说明
type string 设备启动时自动检测的无线类型,broadcom平台类型为brcm-2.4,atheros平台为madwifi或mac80211
channel 数字或‘auto’ 使用的无线频道

wifi-iface 配置项 wifi-iface 的设置指的是 无线设备 的工作模式,essid,无线加密方式等。 最简单的配置如下:

config 'wifi-iface'
        option 'device'     'wl0'
        option 'network'    'lan'
        option 'mode'       'ap'
        option 'ssid'       'MyWifiAP'
        option 'encryption' 'psk2'
        option 'key'        'secret passphrase'
        

简单介绍配置的常见选项,对比看下wifi detect的输出:

名称 类型 说明
device string 使用的无线设备,必须和wifi-device一节中的配置匹配
mode string 无线网络的模式,ap:接入点模式,wds:桥接器模式,Ad-hoc:独立基本业务集 Monitor:监测模式,用于抓包分析监控,可用于无线网络密码破解
ssid string 无线网络的名称
network string 定义无线所属的网络接口,一般为lan
encryption string 加密方式,wifi-detect的输出为none(不加密),建议使用psk2方式加密
key string 网络加密的密码,如果encryption不为none则在此设置密码

 

更多的配置选项,请参考文末的参考连接【wireless无线配置】。

这里我们就可以去修改无线网络的密码了

vi /etc/config/wireless

修改 wifi-iface的加密

config wifi-iface
    option device   radio0
    option network  lan
    option mode     ap
    option ssid     OpenWrt
    option encryption 'psk2'
   option key '密码'

重启wifi

wifi down
wifi

总结

通过以上两种方式配置网络,我们就可以通过OpenWRT访问网络啦。不过通过命令行方式配置OpenWRT肯定不如网页方式方便和快捷,OpenWRT也提供了LuCI的Web管理界面,通过它我们可以迅速快捷的配置路由器相关属性。 在下一节【LuCI安装配置】中我们详细介绍

参考链接:

 
posted @ 2017-05-27 10:48  emenwin  阅读(19563)  评论(0编辑  收藏  举报