HDU - 1863 畅通工程

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28744    Accepted Submission(s): 12633


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
 

 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
 

 

Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
 

 

Sample Input
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
 

 

Sample Output
3 ?
 

 

Source
 

 

Recommend
lcy
略。
最小生成树kruscal算法。
代码:
#include<iostream>
#include<algorithm>
using namespace std;
const int N=105;
int par[N],rnk[N];
struct node
{
    int x,y,cost;
}a[N*N];
bool cmp(node a,node b)
{
    return a.cost<b.cost; 
}
void init(int n)
{
    for(int i=1;i<=n;i++)
    par[i]=i,rnk[i]=0;
}
int find(int x)
{
    if(x==par[x])return x;
    else return par[x]=find(par[x]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)return ;
    if(rnk[x]<rnk[y])par[x]=y;
    else 
    {
        par[y]=x;
        if(rnk[x]==rnk[y])rnk[x]++;
    }
} 
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n,m;
    while(cin>>n>>m&&n)
    {
        for(int i=0;i<n;i++)
        cin>>a[i].x>>a[i].y>>a[i].cost;
        sort(a,a+n,cmp);
        int ans=0;
        init(m);
        for(int i=0;i<n;i++)
        if(find(a[i].x)!=find(a[i].y))
        unite(a[i].x,a[i].y),ans+=a[i].cost;
        int vis[N]={
            0
        };
        for(int i=1;i<=m;i++)
        vis[find(i)]=1;
        int cnt=0;
        for(int i=1;i<=m;i++)
        if(vis[i])cnt++;
        if(cnt==1)cout<<ans<<endl;
        else cout<<"?"<<endl;
    }
    return 0;
} 

 

posted @ 2017-04-21 21:30  Wisdom+.+  阅读(196)  评论(0编辑  收藏  举报