ACM POJ 3370 Halloween treats

Halloween treats

Time Limit: 2000MS
Memory Limit: 65536KB
64bit IO Format: %I64d & %I64u

[Submit]   [Go Back]   [Status

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an(1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source

Ulm Local 2007

 

基本就是上一题的代码,改改变量,注意要注意溢出,要把a[i]先mod n

#include <cstdio>
#include <cstring>
const int N = 100005;
int a[N],sum[N],visit[N] ;
 
int n;
 
void print(int i,int j)
{
    for(int k=i; k<j; k++)
    {
        printf("%d ",k);
    }
    printf("%d\n",j);
    return ;
}
 
int main()
{
    int n,c;
    while(scanf("%d%d",&n,&c))
    {
        if(c == 0&&n == 0)
            return 0;
 
        sum[0] = 0;
        memset(visit,0,sizeof(visit));
        for(int i=1; i<=c; i++)
        {
            scanf("%d",&a[i]);
            sum[i] = (a[i]%n + sum[i-1]) % n;
        }
 
        bool flag = false;
        for(int i = 1; i<=c; i++)
        {
            if(sum[i] == 0)
            {
                print(1,i);
                flag = true;
                break;
            }
            else
            {
                if(visit[sum[i]]!= 0)
                {
                    print((visit[sum[i]]+1),i);
                    flag = true;
                    break;
                }
                else
                {
                    visit[sum[i]]=i;
                }
            }
 
        }
        if(!flag)
            puts("no sweets");
    }
}
posted @ 2013-08-08 11:03  围剿大叔  阅读(250)  评论(0编辑  收藏  举报