maven 打包Could not resolve dependencies for project和无效的目标发行版: 1.8

1.maven 打包Could not resolve dependencies for project

最近项目上使用的是idea ide的多模块话,需要模块之间的依赖,比如说系统管理模块依赖授权模块进行认证和授权,而认证授权模块需要依赖系统管理模块进行,然后,我就开始相互依赖,然后出现这样的问题:

“Could not resolve dependencies for project”,让我百思不得其解,最后网络搜了搜,最后给的解决方案是:

我也碰到这个问题,需要把parent工程,也就是package是pom的那个工程先install一下

然后我就找parent下面的pom,找到<packaging>标签里是pom的那个包,然后install了一下,就好了。原因未知,但是的确救了很多碰到相似问题的人

简单一句话:对着父项目先 clean install 然后子项目clean package发布  ok

2.maven 打包无效的目标发行版: 1.8

保证所有打包的项目 使用的jdk为1.8的版本 

 

posted @ 2017-12-19 15:21  不再_单纯  阅读(39387)  评论(4编辑  收藏