poj 3687

Labeling Balls
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11523   Accepted: 3313

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<string>
#include<vector>
#include<map>
#include<queue>
using namespace std;
vector<int> e[210],ans;
int n,m,in[210],mp[210][210];
void topsort()
{
    priority_queue<int> q;
    for(int i=1;i<=n;i++)
    {
        if(in[i]==0)
            q.push(i);
    }
    while(!q.empty())
    {
        int x=q.top();
        q.pop();
        ans.push_back(x);
        for(int i=0;i<e[x].size();i++)
        {
            int v=e[x][i];
            if(--in[v]==0)
                q.push(v);
        }
    }
}
int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        ans.clear();
        memset(in,0,sizeof(in));
        memset(mp,0,sizeof(mp));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            e[i].clear();
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(!mp[y][x])
            {
                e[y].push_back(x);
                in[x]++;
            }
            mp[y][x]=1;
        }
        topsort();
        if(ans.size()!=n)
            printf("-1\n");
        else
        {
            for(int i=ans.size()-1;i>=1;i--)
                printf("%d ",ans[i]);
            printf("%d\n",ans[0]);
        }
    }
    return 0;
}

  

posted @ 2015-05-25 17:42  waterfull  阅读(251)  评论(0编辑  收藏  举报