(母函数) hdu 1085

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16562    Accepted Submission(s): 7443


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

 

Sample Input
1 1 3 0 0 0
 

 

Sample Output
4
 

 

Author
lcy
 
题目大意:
 
就是有 n1,n2,n3个 1 2 5 价值的硬币,问不能组成的最小整数为多大
 
直接母函数,母函数变式
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<set>
using namespace std;
int num[4],val[4];
int c1[8005],c2[8005],maxx;
int main()
{
    val[1]=1,val[2]=2,val[3]=5;
    while(scanf("%d%d%d",&num[1],&num[2],&num[3])!=EOF)
    {
        if(num[1]+num[2]+num[3]==0)
            break;
        maxx=num[1]+2*num[2]+5*num[3];
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        for(int i=0;i<=num[1];i++)
            c1[i]=1;
        for(int i=2;i<=3;i++)
        {
            for(int j=0;j<=maxx;j++)
            {
                if(c1[j])
                {
                    for(int k=0;k<=val[i]*num[i];k+=val[i])
                    {
                        if(k+j<=maxx)
                            c2[k+j]+=c1[j];
                    }
                }
            }
            for(int j=0;j<=maxx;j++)
                c1[j]=c2[j],c2[j]=0;
        }
        int i;
        for(i=1;i<=maxx;i++)
        {
            if(c1[i]==0)
            {
                printf("%d\n",i);
                break;
            }
        }
        if(i==maxx+1)
            printf("%d\n",maxx+1);
    }
    return 0;
}

  

posted @ 2015-04-27 20:14  waterfull  阅读(114)  评论(0编辑  收藏  举报