坦克大战

算法:广搜+优先队列

描述
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).



Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
输入The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
样例输入3 4
YBEB
EERE
SSTE
0 0
样例输出

8

代码:

   #include <iostream>  
   #include <cstring>  
   #include <algorithm>  
   #include <iomanip>  
   #include <queue>  
   #include <string>  
   #include <stdio.h>
   using namespace std;
   char ch[305][305];
   int a[303][303];
   int b[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
   int n,m,ex,ey;
   struct dot
   {
   	   int x,y,step;
   	   bool friend operator<(dot nod1,dot nod2)
   	   {return nod1.step>nod2.step;}
   } ;
   int bfs(int ap,int aq)
   {
   	  priority_queue<dot>que;
   	  dot cur,loer;
   	  cur.x=ap;cur.y=aq;cur.step=0;
   	  memset(a,0,sizeof(a));
   	  a[ap][aq]=1;
   	  que.push(cur);
   	  while(que.size())
   	  {
   	  	loer=que.top();
   	  	que.pop();
   	  	if(loer.x==ex&&loer.y==ey) return loer.step;
   	  	for(int i=0;i<4;i++)
   	  	{
   	  		int dx=loer.x+b[i][0];
   	  		int dy=loer.y+b[i][1];
   	  		if(dx>=0&&dx<n&&dy>=0&&dy<m&&a[dx][dy]==0&&ch[dx][dy]!='R'&&ch[dx][dy]!='S')
   	  		{
   	  			if(ch[dx][dy]=='B')
   	  			{
   	  				cur.step=loer.step+2;
   	  				cur.x=dx;cur.y=dy;
   	  				a[dx][dy]=1;
   	  				que.push(cur);
				}
				else if(ch[dx][dy]=='T'||ch[dx][dy]=='E')
				{
					cur.step=loer.step+1;
					cur.x=dx;cur.y=dy;
					que.push(cur);
					a[dx][dy]=1;
				}
			}
		}
	  }
	  return -1;
   }
   int main()
   {
   	int i,j,p,q;
   	while(cin>>n>>m&&n&&m)
   	{
   		for(i=0;i<n;i++)
   		{
   			for(j=0;j<m;j++)
			{
			    cin>>ch[i][j];
				if(ch[i][j]=='Y')
				{
					p=i;q=j;
				}  	
				if(ch[i][j]=='T')
				{
					ex=i;ey=j;
				}
			} 
		}

		cout<<bfs(p,q)<<endl;
	}
	return 0;
   }


posted @ 2016-03-22 10:33  (慎独)  阅读(293)  评论(0编辑  收藏  举报