ubuntu16.04下opencv安装笔记和例程

问题:

最近重装了系统,需要重新配置opencv2.4.13,配置完成后每次都出现cmake error,google了报错,尝试了各种方法,都未解决问题,于是重新git clone 了opencv2.4.9,发现出现了同样的问题和报错。

解决方法:

刚开始没更新版本之前折腾了两天,后来感觉特别没有成就感,便慢慢放下了这件事,开始学习自己的研究生课程,学习枯燥的时候又尝试重新安装了下,终于跑通了例程,贴出例程和测试结果

测试例程:

新建demo文件夹

新建demo.cpp,把下面代码复制黏贴:

#include <opencv2/core/core.hpp>
#include <opencv2/viz/vizcore.hpp>

int main()
{
cv::viz::Viz3d window = cv::viz::Viz3d("Viz demonstration");

cv::Point3d min(0.25, 0.0, 0.25);
cv::Point3d max(0.75, 0.5, 0.75);

cv::viz::WCube cube(min, max, true, cv::viz::Color::blue());
cube.setRenderingProperty(cv::viz::LINE_WIDTH, 4.0);

window.showWidget("Axis widget", cv::viz::WCoordinateSystem());
window.showWidget("Cube widget", cube);

while(!window.wasStopped()) {
window.spinOnce(1, true);
}

return 0;
}

新建CMakeLists.txt文件夹,复制黏贴以下代码:

 

cmake_minimum_required(VERSION 2.8.12)

 

project(demo)

 

find_package(OpenCV REQUIRED)
include_directories(${OpenCV_INCLUDE_DIRS})

 

add_executable(demo demo.cpp)
target_link_libraries(demo ${OpenCV_LIBS})

 

编译

cd demo

mkdir build

cd build

cmake ..

make

./demo

测试结果如下:

 

posted @ 2016-11-14 18:31  月亮下,六便士  阅读(1042)  评论(0编辑  收藏