NPM——Electron failed to install correctly, please delete node_modules/electron and try

前言

electron项目启动的时候报错Error: Electron failed to install correctly, please delete node_modules/electron and try

  • 仔细查看报错信息 | 根本要点
  • 代理网络

内容

版本问题

## electron版本过高(本地electron安装的是最新版本v13.1.6 | 实际需要的版本是v8.5.5) | 解决方法如下重新安装指定版本
PS C:\Users\WangYang> npm install -g electron@8.5.5

安装问题

## electron安装失败(原来是项目里配置走了淘宝镜像) | 解决方法我直接把全局的安装的文件拷贝到项目中了,当然也可以直接link下

安装依赖的时候要注意看下是否有其他的报错, 比如我这个项目就有一个报错提示我使用的node版本过低

代理网络

## 删除项目中相关的配置或配置文件 | 我这边就以下两个文件
## 代理网络
## package.json中的taobao的npm配置
## .nrm配置文件
## npm install

因为曾经被淘宝的npm镜像坑过,所以从哪以后再也没用过淘宝的npm镜像,没想到这次...

运行项目

打包项目

学无止境,谦卑而行.
posted @ 2021-07-10 23:51  。思索  阅读(314)  评论(0编辑  收藏  举报