YouCompleteMe unavailable: requires Vim compiled with Python 2.x support

问题:YouCompleteMe unavailable: requires Vim compiled with Python 2.x support

解决:重新编译,加入--enable-pythoninterp=yes参数。如果想开启Python3支持,则--enable-python3interp=yes

./configure --with-features=huge --enable-pythoninterp=yes --enable-cscope --enable-fontset --with-python-config-dir=/usr/lib64/python3.6/config-3.6m-x86_64-linux-gnu --enable-pythoninterp=yes --enable-python3interp=yes
make
make install

 

posted @ 2019-09-24 10:24  wangjq_china  阅读(1810)  评论(0编辑  收藏