Invitation Cards dijkstra法

In the age of television, not many people attend theater performances.
Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these
invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer
is to move to one predetermined stop to invite passengers. There are
as many volunteers as stops. At the end of the day, all students
travel back to CCS. You are to write a computer program that helps ACM
to minimize the amount of money to pay every day for the transport of
their employees.

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210

题目大意:
求某一点到其他n-1个点的最短距离,其他n-1个点到该点的最短距离,求出两者之和然后输出。

解题思路:某一点到其他n-1个点的距离可以用dijkstra模板做,但求其他n-1个点类似的题是以前不曾见过的,其实只要将每条路径翻转,再求该点到其他点的最短路径,就是其他点到该点的最短路径。
写的不是很清楚,多读两遍应该就清楚了。另外此题会爆int,所以应用longlong存储。

Code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
typedef long long ll;
const int maxn = 1e6+5;
int n,m,cnt=0,vis[maxn],head[maxn];
int u[maxn],v[maxn];
ll w[maxn],dis[maxn];

struct node{
	int w,to,next;
};
node edge[maxn];
void add(int u,int v,int w){
	edge[cnt].w=w;
	edge[cnt].to=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
struct road{
	int dis,pos;
	friend bool operator < (road a,road b){
		return a.dis>b.dis;
	}
};
void dijkstra(){
	memset(dis,0x3f,sizeof(dis));
	memset(vis,0,sizeof(vis));
	dis[1]=0;
	priority_queue<road>q;
	q.push((road){dis[1],1});
	while(!q.empty()){
		road p=q.top();
		q.pop();
		int u=p.pos;
		if(vis[u]) continue;
		vis[u]=1;
		for(int i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].to;
			if(dis[v]>dis[u]+edge[i].w){
				dis[v]=dis[u]+edge[i].w;
			}
			q.push((road){dis[v],v});//一些c++提交上去是违规的,大佬那种高操作的不太会,实在不行,可以一个一个元素入队 
		}
	}	
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		memset(head,-1,sizeof(head));
		cnt=0;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=m;i++){
			scanf("%d%d%lld",&u[i],&v[i],&w[i]);
			add(u[i],v[i],w[i]);
		}		
		dijkstra();
		ll sum=0;
		for(int i=2;i<=n;i++){
			sum+=dis[i];
		}
		memset(head,-1,sizeof(head));
		cnt=0;
		for(int i=1;i<=m;i++){
			add(v[i],u[i],w[i]);
		}
		dijkstra();
		for(int i=1;i<=n;i++){
			sum+=dis[i];
		}
		cout<<sum<<endl;
	}
	
	return 0;
}
posted @ 2019-08-06 18:01  voids5  阅读(113)  评论(0编辑  收藏  举报