HDU 5982 Relic Discovery (2016年青岛区域赛A题——水题)

Recently, paleoanthropologists have found historical remains on an island in the Atlantic Ocean. The most inspiring thing is that they excavated in a magnificent cave and found that it was a huge tomb. Inside the construction,researchers identified a large number of skeletons, and funeral objects including stone axe, livestock bones and murals. Now, all items have been sorted, and they can be divided into N types. After they were checked attentively, you are told that there are Ai items of the i-th type. Further more, each item of the i-th type requires Bi million dollars for transportation, analysis, and preservation averagely. As your job, you need to calculate the total expenditure.

Input

The first line of input contains an integer T which is the number of test cases.

For each test case, the first line contains an integer N which is the number of types. In the next N lines, the i-th line contains two numbers Ai and Bi as described above. All numbers are positive integers and less than 101.

Output

For each case, output one integer, the total expenditure in million dollars, on a line by itself.

Sample Input

1

2

1 2

3 4

Sample Output

14

题解:

防爆0题,不多说了,就是拼阅读速度手速和胆量。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int main(){
	
	int T,N;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&N);
		int sum = 0;
		for(int i=1 ; i<=N ; ++i){
			int a,b;
			scanf("%d %d",&a,&b);
			sum += a*b;
		}
		printf("%d\n",sum);
	}
	
	return 0;
} 

 

posted @ 2018-07-20 20:43  Assassin_poi君  阅读(247)  评论(0编辑  收藏  举报