Loading

1031 Hello World for U (20 分)

1. 题目

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | kn2 for all 3≤n2≤N } with n1+n2+n3−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

2. 题意

将一串字符串以U型形式输出出来。

3. 思路——字符串

根据题意计算n1,n2,n3,这里n1等于n3,只要定义n1和n2即可。

计算方法:

​ 已知:n1=n3=max {k | k≤n2 for all 3≤n2≤N },且n1+n2+n3-2=N

​ 可得:\(n1=n3=(N+2)/2\)(结果向下取整)

\(n2=N+2-n1-n3\)

计算出n1和n2后,即可根据题目要求输出U型图形(见代码)。

4. 代码

#include <iostream>
#include <string>

using namespace std;

int main()
{
	string str;
	cin >> str;
	int n1, n2;
	int N = str.length();
	n1 = (N + 2) / 3;
	n2 = N + 2 - (2 * n1);
	for (int i = 0; i < n1 - 1; ++i)
	{
		// 输出第i个字符 
		cout << str[i];	
		// 输出中间的空格 
		for (int j = 0; j < n2 - 2; ++j) cout << " ";
		// 输出倒数第i+1个字符 
		cout << str[N - 1 - i] << endl;	
	}
	// 最后一行输出剩下的中间字符串 
	cout << str.substr(n1 - 1, n2) << endl;
	return 0;
}
 

posted @ 2021-10-30 13:02  August_丶  阅读(33)  评论(0编辑  收藏  举报