代码改变世界

解决:gradle 前言中不允许有内容

2020-06-13 12:22  蓝之风  阅读(1713)  评论(0编辑  收藏  举报

将Android Studio 升级到4.0然后创建一个新项目,编译出现“ gradle 前言中不允许有内容” 的错误,在网上找了很多资料,众说纷纭,但都没有解决我的问题,最后反复摸索把问题解决了。

1.清除gradle的所有缓存。

2.修改gradle 的版本,4.0支持的最的gradle  版本是6.1.1 所以修改文件 gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-6.1.1-all.zip

3.更新android SDK 到29,并将编译配置如下

android {
    compileSdkVersion 29

    defaultConfig {
        applicationId "com.example.myapplication"
        minSdkVersion 16
        targetSdkVersion 29
        versionCode 1
        versionName "1.0"

        testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
        }
    }
}

4.重新编译,工作正常。

总结: 这次出问题的主要原因是,  gradle 的版本不匹配,第二急是android的sdk版本不匹配当前的androidx,升级gradle 和sdk就是解决这两个问题。


作者:蓝之风
出处:http://www.cnblogs.com/vaiyanzi/
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。