HDU 1029 Ignatius and the Princess IV

          HDU 1029 Ignatius and the Princess IV

          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
               Total Submission(s): 40133    Accepted Submission(s): 17492

Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 
Output
For each test case, you have to output only one line which contains the special number you have found.
 
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
 
Sample Output
3
5
1
 
思路:将每组数据的数按一定顺序排列(从大到小或从小到大均可)。因为最后结果至少出现 ( n + 1 ) / 2 次,所以最中间的数一定是结果
(思路来自啊哈雷的《啊哈算法》第9章) 
//好短的代码。。。
#include<algorithm>
#include<cstdio>
using namespace std;
int n;
int a[1000000];

int main() {
    while(scanf("%d", &n) != EOF) {
        for(int i = 0; i < n; i++) scanf("%d", &a[i]);
        sort(a, a+n);
        int mid = n / 2;
        printf("%d\n", a[mid]);
    }
    return 0;
}

Ps:  《啊哈算法 · 第9章 还能更好吗?——微软亚洲研究院面试》

 

posted @ 2018-04-02 21:59  落云小师妹  阅读(131)  评论(0编辑  收藏  举报