Calls to static methods in Java interfaces are prohibited in JVM target 1.6. Recompile with '-jvm-target 1.8'

这个问题出现在使用idea编译kotlin代码时(java项目)
需要在gradle中执行编译的版本

compileKotlin {
	kotlinOptions.jvmTarget = "1.8"
}
compileTestKotlin {
	kotlinOptions.jvmTarget = "1.8"
}
compileJava {
	targetCompatibility = 1.8
	sourceCompatibility = 1.8

}
posted @ 2020-10-14 10:27  君君的喵爸  阅读(686)  评论(0编辑  收藏  举报