代码改变世界

OSPF配置

2019-05-29 22:34  tyrr  阅读(1465)  评论(20编辑  收藏  举报

ipv4 & ipv6 ospf 配置(学号后两位14)

Ipv4:实验拓扑

 

 

地址规划:

Device

Interface

IP Address

R1

F 0/0

10.14.1.1/24

F 0/1

10.14.2.1/24

R2

S 0/0

10.14.3.1/24

F 0/0

10.14.1.2/24

R3

S 0/0

192.168.14.3/24

F 0/0

10.14.1.3/24

R5

S 0/0

10.1.14.5/24

R6

S 0/0

192.168.14.6/24

R7

F 0/1

10.14.2.2/24

S 0/0

10.14.3.2/24

F 0/0

10.14.4.7/24

R8

F 0/0

10.14.4.8/24

 

 

帧中继配置

FR(config)#int s0/2

FR(config-if)#no shutdown

FR(config-if)#clock rate 148000

FR(config-if)#encapsulation frame-relay

FR(config)#int s0/0

FR(config-if)#no shutdown

FR(config-if)#clock rate 148000

FR(config-if)#encapsulation frame-relay

FR(config)#int s0/1

FR(config-if)#no shutdown

FR(config-if)#clock rate 148000

FR(config-if)#encapsulation frame-relay

FR(config)#int s0/2

FR(config-if)#frame-relay lmi-type cisco

FR(config-if)#frame-relay intf-type dce

FR(config)#int s0/0

FR(config-if)#frame-relay lmi-type cisco

FR(config-if)#frame-relay intf-type dce

FR(config)#int s0/1

FR(config-if)#frame-relay lmi-type cisco

FR(config-if)#frame-relay intf-type dce

FR(config)#int s0/2

FR(config-if)#frame-relay route 103 interface s0/1 301

FR(config-if)#frame-relay route 104 int s0/0 401

FR(config)#int s0/0

FR(config-if)#frame-relay route 301 int s0/2 103

FR(config)#int s0/1

FR(config-if)#frame-relay route 401 int s0/2 104

FR#show frame-relay rou

FR#show frame-relay route

Input Intf      Input Dlci      Output Intf     Output Dlci     Status

Serial0/0       401             Serial0/2       104             inactive

Serial0/1       301             Serial0/2       103             inactive

Serial0/2       103             Serial0/0       301             inactive

Serial0/2       104             Serial0/1       401             inactive

 

 

 

配置动态映射

R6(config-if)#encapsulation frame-relay R3(config)#int s0/2

R3(config-if)#ip address 10.14.10.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#encapsulation frame-relay

R3(config-if)#frame-relay lmi-type cisco

R3(config-if)#end

 

R5(config)#int s0/0

R5(config-if)#ip address 10.14.10.5 255.255.255.0

R5(config-if)#no shutdown

R5(config-if)#encapsulation frame-relay

R5(config-if)#end

 

R6(config)#int s0/1

R6(config-if)#ip address 10.14.10.6 255.255.255.0

R6(config-if)#no shutdown

 

R6(config-if)#end

检验

R3#ping 10.14.10.5

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.26.14.5, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/59/172 ms

R3#ping 10.14.10.6

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.14.10.6, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 14/23/44 ms

 

FR(config)#int s0/1

FR(config-if)#frame-relay route 403 int s1/1 304

FR(config)#int s0/0

FR(config-if)#frame-relay route 304 int s1/0 403

 

R6#ping 10.14.10.5

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.26.10.5, timeout is 2 seconds:

!!!!!

ospf配置:以R2为例

 

R2(config)#int f0/0

R2(config-if)#ip address 10.14.20.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#int s0/0

R2(config-if)#ip address 10.14.30.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#int loopback 0

R2(config-if)#ip address 2.2.2.2 255.255.255.0

R2(config-if)#exit

R2(config)#int loopback 0

R2(config-if)#ip address 2.2.2.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

 

R2(config)#router ospf 1

R2(config-router)#router-id 2.2.2.2

R2(config-router)#network 10.14.14.0 0.0.0.255 are

R2(config-router)#network 10.14.14.0 0.0.0.255 area 0

R2(config-router)#network 10.14.20.0 0.0.0.255 area 0

R2(config-router)#network 2.2.2.2 0.0.0.255 area 0

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ipv6:实验拓扑

帧中继R2配置与ospfv2相同。

1.完成接口 IPv6 地址的配置,注意不要忘记配置 loopback0:

R1(config)#ipv6 unicast-routing ―――全局打开 IPv6 路由功能

R1config)#interface loopback 0

R1(config-if)#ipv6 enable

R1(config-if)#ipv6 address 2011::1/148―――配置 loopback0 接口地址

R1(config-if)#int f 0/0

R1(config-if)#ipv6 enable

R1(config-if)# ipv6 address 2143::14:1/64

R1(config-if)#no shut

R1(config-if)#int s 1/0

R1(config-if)#ipv6 enable

R1(config-if)# encapsulation frame-relay

R1(config-if)#no shut

R1(config)#interface serial 1/0.1 multipoint

R1(config-subif)#ipv6 address 2356::14:1/64

R1(config-subif)#frame-relay map ipv6 2356::14:3 103 broadcast 

R1(config-subif)#frame-relay map ipv6 2356::14:4 104 broadcast

R1(config-subif)#frame-relay map ipv6 2356::14:1 104 broadcast

R1(config-subif)#frame-relay map ipv6 FE80::C804:1CFF:FE48:8 104 broadcast

R1(config-subif)#frame-relay map ipv6 FE80::C803:1CFF:FE48:8 103 broadcast

 

 

 

R3(config)#ipv6 unicast-routing

R3(config)#interface loopback 0

R3(config-if)#ipv6 address 2033::1/148

R3(config-if)#int s 1/0

R3(config-if)#ipv6 enable

R3(config-if)# encapsulation frame-relay

R3(config-if)#no shutdown

R3(config)#interface serial 1/0.1 multipoint

R3(config-subif)#ipv6 address 2356::14:3/64

R3(config-subif)#frame-relay map ipv6 2356::14:1 301 broadcast 

R3(config-subif)#frame-relay map ipv6 2356::14:4 301 broadcast

R3(config-subif)#frame-relay map ipv6 2356::14:3 301 broadcast

R3(config-subif)#frame-relay map ipv6 FE80::C804:1CFF:FE48:8 304 broadcast

R3(config-subif)#frame-relay map ipv6 FE80::C801:1CFF:FE48:8 301 broadcast

 

R4(config)#ipv6 unicast-routing

R4(config)#interface loopback 0

R4(config-if)#ipv6 address 2044::1/148

R4(config-if)#int s 1/0

R4(config-if)#ipv6 enable

R4(config-if)# encapsulation frame-relay

R4(config-if)#no shutdown

R4(config)#interface serial 1/0.1 multipoint

R4(config-subif)#ipv6 address 2356::14:4/64

R4(config-subif)#frame-relay map ipv6 2356::14:1 401 broadcast 

R4(config-subif)#frame-relay map ipv6 2356::14:4 401 broadcast

R4(config-subif)#frame-relay map ipv6 2356::14:3 401 broadcast

R4(config-subif)#frame-relay map ipv6 FE80::C803:1CFF:FE48:8 403 broadcast

R4(config-subif)#frame-relay map ipv6 FE80::C801:1CFF:FE48:8 401 broadcast

 

用show frame-relay pvc命令查看,帧中继配置完成

 

 

 

 

2.  按实验拓扑图标识的区域,完成 OSPFv3 的基本配置。区域 1 为 NSSA 区域。

R6(config)#ipv6 unicast-routing

R6(config)#ipv6 router ospf 1―――启动 OSPFv3 进程

R6(config-rtr)#router-id 6.6.6.6

R6(config-rtr)#area 1 nssa――配置区域 1 为 NSSA 区域

R6(config-rtr)#int f 0/0

R6(config-if)#ipv6 enable

R6(config-if)# ipv6 ospf 1 area 0

R6(config-if)#no shutdown

R6(config-if)#int loopback 0

R6(config-if)#ipv6 enable

R6(config-if)#ipv6 address 2066::1/148

R6(config-if)# ipv6 ospf 1 area 0

R6(config-if)#int f 0/1

R6(config-if)#ipv6 enable

R6(config-if)# ipv6 ospf 1 area 1

R6(config-if)#no shutdown

 

 

R5(config)#ipv6 unicast-routing

R5(config)#ipv6 router ospf 1―――启动 OSPFv3 进程

R5(config-rtr)#router-id 5.5.5.5

R5(config-rtr)#area 1 nssa――配置区域 1 为 NSSA 区域

R5(config-rtr)#int f 0/0

R5(config-if)#ipv6 enable

R5(config-if)# ipv6 ospf 1 area 0

R5(config-if)#no shutdown

R5(config-if)#int loopback 0

R5(config-if)#ipv6 enable

R5(config-if)#ipv6 address 2055::1/148

R5(config-if)# ipv6 ospf 1 area 0

R5(config-if)#int s 1/0

R5(config-if)#ipv6 enable

R5(config-if)# ipv6 ospf 1 area 1

R5(config-if)#no shutdown

 

 

 

R1(config)#ipv6 unicast-routing

R1(config)#ipv6 router ospf 1―――启动 OSPFv3 进程

R1(config-rtr)#router-id 1.1.1.1

R1(config-rtr)#int f 0/0

R1(config-if)#ipv6 enable

R1(config-if)# ipv6 ospf 1 area 0

R1(config-if)#no shutdown

R1(config-if)#int loopback 0

R1(config-if)#ipv6 enable

R1(config-if)#ipv6 address 2011::1/148

R1(config-if)# ipv6 ospf 1 area 0

R1(config-if)#int s 1/0.1

R1(config-subif)#ipv6 enable

R1(config-subif)# ipv6 ospf 1 area 2

R1(config-subif)#ipv6 ospf neighbor FE80::C803:1CFF:FE48:8

R1(config-subif)#ipv6 ospf neighbor FE80::C804:1CFF:FE48:8

 

R3(config)#ipv6 router ospf 1

R3(config-rtr)#router-id 5.5.5.5

R3(config-rtr)#int loopback 0

R3(config-if)#ipv6 enable

R3(config-if)#ipv6 address 2033::1/148

R3(config-if)# ipv6 ospf 1 area 2

R3(config-if)#int s 1/0.1

R3(config-subif)#ipv6 enable

R3(config-subif)# ipv6 ospf 1 area 2

R3(config-subif)# ipv6 ospf priority 0

R3(config-subif)# ipv6 address FE80::C803:1CFF:FE48:8 link-local

 

R4config)#ipv6 router ospf 1

R4config-rtr)#router-id 4.4.4.4

R4config-rtr)#int loopback 0

R4config-if)#ipv6 enable

R4(config-if)#ipv6 address 2044::1/148

R4(config-if)# ipv6 ospf 1 area 2

R4(config-if)#int s 1/0.1

R4(config-subif)#ipv6 enable

R4(config-subif)# ipv6 ospf 1 area 2

R4(config-subif)# ipv6 ospf priority 0

R4(config-subif)# ipv6 address FE80::C804:1CFF:FE48:8 link-local

 

 

R8(config)#ipv6 unicast-routing

R8(config)#ipv6 router ospf 1―――启动 OSPFv3 进程

R8(config-rtr)#router-id 8.8.8.8

R8(config-rtr)#area 1 nssa――配置区域 1 为 NSSA 区域

R8(config-rtr)#int s 1/0

R8(config-if)#ipv6 enable

R8(config-if)# ipv6 ospf 1 area 1

R8(config-if)#no shutdown

R8(config-if)#int loopback 0

R8(config-if)#ipv6 enable

R8(config-if)#ipv6 address 2088::1/148

R8(config-if)# ipv6 ospf 1 area 1

R8(config-if)#int f 0/1

R8(config-if)#ipv6 enable

R8(config-if)# ipv6 ospf 1 area 1

R8(config-if)#no shutdown

3.检查 OSPFv3 的邻居关系

在 R31上检查,可以看到邻居的 Router-ID 都是用 IPv4 的地址格式标识

R1#show ipv6 ospf neighbor

 

4.测试路由通断情况在R3测试。Ospfv3配置成功。

 

 

本实验步骤引入外部路由类型 5 和外部路由类型 7

1) 在 R6 上新增加一个 loopback1 接口,地址为 2166::1/148,然后重分布进入 OSPFv3

R6(config)#interface loopback 1

R6(config-if)#ipv6 address 2166::1/148

R6(config-if)#exit

R6(config)#ipv6 router ospf 1

R6(config-rtr)#redistribute connected

配置 R7 和 R8 的 RIPng,然后重分布 RIPng 到 OSPFv3

R7(config)#ipv6 router rip yeslab

R7(config-rtr)#exit

R7(config)#interface fastEthernet 0/0

R7(config-if)#ipv6 rip yeslab enable

R7(config-if)#exit

 

R8(config)#ipv6 router rip yeslab

R8(config-rtr)#exit

R8(config)#interface fastEthernet 0/0

R8(config-if)#ipv6 rip yeslab enable

R8(config-if)#exit

R8(config)#ipv6 router ospf 1

R8(config-rtr)#redistribute rip yeslab―――重分布 RIPng 到 OSPFv3

R8(config-rtr)#redistribute connected―――由于重分布 RIPng,不能把连接 R8 的接口网段重分布进入OSPFv3,因此重分布直连,把连接 R8 的网段重分布到 OSPFv3

 

 

 

 

 

实验心得:

本次实验还是挺有难度的,对于如何配置ospf和ipv6琢磨了很久,也请教了不少同学,和组员间也进行了探讨,本次实验让我明白自己对很多知识点和操作指令还是不太熟悉,需要多加努力。