随笔分类 - Linux
与Linux相关的
Linux与Windows的几点区别
摘要:echo $PATH 回显Linux环境变量PATH的值,Linux下的环境变量必须大写echo %path% 回显Windows环境变量path的值 export PATH=/usr/local/tomcat 修改设置Linux环境变量PATH的值(临时),Linux文件系统路径是斜杠set pa
阅读全文
Linux文件编辑时光标操作
摘要:一、移动光标类命令 h :光标左移一个字符 l :光标右移一个字符 space:光标右移一个字符 Backspace:光标左移一个字符 k或Ctrl+p:光标上移一行 j或Ctrl+n :光标下移一行 Enter :光标下移一行 w或W :光标右移一个字至字首 b或B :光标左移一个字至字首 e或E
阅读全文
Linux文件编辑vi、mkdir等
摘要:1、进入vi的命令 vi filename :打开或新建文件,并将光标置于第一行首 vi +n filename :打开文件,并将光标置于第n行首 vi + filename :打开文件,并将光标置于最后一行首 vi +/pattern filename:打开文件,并将光标置于第一个与pattern
阅读全文
Linux下tomcat运行时jvm内存分配
摘要:tomcat运行时jvm内存分配 ⑴开发环境下在myeclipse中配置-Xms256m -Xmx512m -XX:NewSize=64m -XX:MaxNewSize=128m -XX:PermSize=512m-XX:MaxPermSize=512m ⑵,线上环境(直接通过catalina或st
阅读全文
Linux搜索文件或内容
摘要:1、递归搜索文件内容,如果查找"hello,world!"字符串,可以这样: grep -rn "hello,world!" * * : 表示当前目录所有文件,也可以是某个文件名 -r 是递归查找 -n 是显示行号 -R 查找所有文件包含子目录 -i 忽略大小写 2、搜索文件 find / -nam
阅读全文
Linux压缩和解压缩
摘要:1.tar.gz tar.gz这种格式是Linux下使用得最多的压缩格式。它在压缩时不会占用太多CPU的,而且可以得到一个非常理想的压缩率。 tar -zcvf archive_name.tar.gz directory_to_compress -->压缩一个目录 tar -zxvf archive
阅读全文
Linux查询日志内容
摘要:1.查询日志中含有某个关键字的信息 cat app.log |grep 'error' 2.查询日志尾部最后10行的日志 tail -n 10 app.log 3.查询10行之后的所有日志 tail -n +10 app.log 4.查询日志文件中的头10行日志 head -n 10 app.log
阅读全文
Linux创建用户与权限赋值
摘要:1.设置文件的权限 1).解说: d:是英语directory的缩写,表示“目录”。就是说这是一个目录。 l:是英语link的缩写,表示“链接”。就是说这是一个链接。 b:块设备文件 c:字符设备 s:套接字文件 r:是英语read的缩写,表示“读”。就是说可以读这个文件。 w:是英语write的缩
阅读全文
查看Linux磁盘空间
摘要:df -hl 查看磁盘剩余空间 df -h 查看每个根路径的分区大小 du -sh [目录名] 返回该目录的大小 du -sm [文件夹] 返回该文件夹总M数 du -h [目录名] 查看指定文件夹下的所有文件大小(包含子文件夹)
阅读全文
Linux下修改Jenkins默认端口
摘要:我是自动安装的Jenkins,默认目录为 jenkins安装目录:/var/lib/jenkins jenkins日志目录:/var/log/jenkins/jenkins.logjenkins默认配置:/etc/default/jenkins 修改端口要到,jenkins默认配置中修改,修改完后保
阅读全文
Linux下设置redis的密码和远程访问
摘要:编辑vi /etc/redis/redis.conf ,有的是vi /etc/redis.conf ,在68行修改:bind 127.0.0.1 ::1 为 bind 0.0.0.0 ::1,这样就可以远程访问了。 然后修改密码,默认为:foobared,如果不想默认的,就修改一个自己想要的密码。
阅读全文
linux下设置mysql5.7数据库远程访问
摘要:1.在网上看了很多关于设置远程访问的方式,根本就不起作用,后来在网上看到有一篇文章终于解决了我的问题,在配置文件中 /etc/mysql/my.cnf : 2.编辑 vi /etc/mysql/mysql.conf.d/mysqld.cnf 修改里面的 bind-address = 127.0.0.
阅读全文
mysql查询出现In aggregated query without GROUP BY, expression #1 of SELECT list contains nonaggregated column 'zhibo.a.id';
摘要:出现问题: Error querying database. Cause: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: In aggregated query without GROUP BY,expression #2 of
阅读全文
linux下安装mysql解决乱码、时间差、表的大小写问题
摘要:编辑vi /etc/mysql/my.cnf,有的则是:/etc/my.cnf,加入 [client]default-character-set=utf8mb4 [mysql]default-character-set=utf8mb4 [mysqld]lower_case_table_names=1
阅读全文
Linux下使用Nginx代理访问json文件报404错误
摘要:在网上看了很多,都说是IIS的问题,关键是使用servlet就可以正常访问,使用Nginx就不行,最后发现是其他问题,解决方案如下: 1.确认配置的路径是否正确,Nginx代理的路径和你访问的路径。 2.在Nginx的nginx.conf中找到对应的server,然后找到访问静态文件的locatio
阅读全文
浙公网安备 33010602011771号