Ubuntu16.04下安装vim8,并支持python3

 

 

1.首先安装 依赖项如下:

  需要注意的是在Ubuntu16.04中Lua应该为liblua5.1-dev,而在其它版本中应为lua5.1-dev

sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev \
    libgtk2.0-dev libatk1.0-dev libbonoboui2-dev \
    libcairo2-dev libx11-dev libxpm-dev libxt-dev python-dev \
    python3-dev ruby-dev liblua5.1 lua5.1-dev libperl-dev git

2.从github下载vim
  新建一个文件夹存放clone下来的vim,然后在该文件夹下打开终端执行命令:

git clone https://github.com/vim/vim.git

3.查询系统中是否已经含有vim,如果有的话删除系统中vim
  例如我的系统中有vim-common vim-tiny 

dpkg -l | grep vim
sudo apt-get remove vim-common vim-tiny

4. 进入下载的VIM目录,执行下面的操作:

  注意,有的文章中这里同时配置了python2和python3,此时只有python2生效,如果想让vim8支持python3,则只需要配置python3即可,不要配置python2。

./configure --with-features=huge \
            --enable-multibyte \
            --enable-rubyinterp=yes \
            --enable-python3interp=yes \
            --with-python3-config-dir=/usr/lib/python3.5/config \
            --enable-perlinterp=yes \
            --enable-luainterp=yes \
            --enable-gui=gtk2 --enable-cscope --prefix=/usr

  如果想让vim8支持python2,执行下面的操作:

./configure --with-features=huge \
            --enable-multibyte \
            --enable-rubyinterp=yes \
            --enable-pythoninterp=yes \
            --with-python-config-dir=/usr/lib/python2.7/config \
            --enable-perlinterp=yes \
            --enable-luainterp=yes \
            --enable-gui=gtk2 --enable-cscope --prefix=/usr

5. 执行make操作

sudo make VIMRUNTIMEDIR=/usr/share/vim/vim81
sudo make install

6. 查看结果

  执行完上面的操作后,就已经成功安装了vim8,执行下面的命令可以查看一下安装的结果:

vim --version

 7. 推荐一下我的vim配置

Github链接:https://github.com/hfts/tSuai_vim

 

posted @ 2017-09-19 23:44 TPrime.A 阅读(...) 评论(...) 编辑 收藏