判断线段相交 hdu 1086

Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.
 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the number of intersections, and one line one case.
 

Sample Input
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output
1 3

判断两条线段是否相交,就是判断其中一条线段的端点是在另一条的两侧(或在另一条上)

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 110
struct Point{
	double x1,y1;
	double x2,y2;
}p[N];
bool fun(Point a,Point b){
	//y=kx+b   =   y=x*(a.y1-a.y2)/(a.x1-a.x2)+(a.x1*a.y2-a.x2*a.y1)/(a.x1-a.x2)
	double x=b.y1-(b.x1*(a.y1-a.y2)+(a.x1*a.y2-a.x2*a.y1))/(a.x1-a.x2);
	double y=b.y2-(b.x2*(a.y1-a.y2)+(a.x1*a.y2-a.x2*a.y1))/(a.x1-a.x2);
//	printf("%f %f\n",x,y);
	if(x*y<=0)return true;
return false;
}
int main(){
	int n,i,j,cnt;
	while(cin>>n&&n){
		for(i=0;i<n;i++)
			scanf("%lf%lf%lf%lf",&p[i].x1,&p[i].y1,&p[i].x2,&p[i].y2);
		cnt=0;
		for(i=0;i<n;i++)
			for(j=i+1;j<n;j++)
				if(fun(p[i],p[j])&&fun(p[j],p[i]))cnt++;
				printf("%d\n",cnt);
	}
return 0;
}



posted @ 2014-08-12 17:36  疯子乙  阅读(145)  评论(0编辑  收藏  举报