hdoj1162-Eddy's picture(kruskal)

题目链接

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output
3.41

思路:

1.首先读入各点数据,然后再转化为各条边。

2.然后用kruskal算法求解。

//Exe.Time  Exe.Memory
//  0MS      1892K
#include <iostream>
#include <algorithm>
#include <fstream>
#include <cmath>
#include <iomanip>
using namespace std;
//边
struct Edge
{
    int v, u;
    double w;
};

//点
struct Point
{
    double x, y;
};

Edge e[5010];
Point p[105];
int n;
int father[105];
int data[105][105];

int cmp(Edge e1, Edge e2)
{
    return e1.w <= e2.w;
}
//初始化并查集
void init()
{
    for(int i = 0; i <= n; ++ i)
    {
        father[i] = i;
    }
}
//寻找根节点,并按路径优化
int find(int node)
{
    int x = node;
    if(x != father[x])
    {
        father[x] = find(father[x]);
    }
    return father[x];
}
//合并两个集合
void unit(int x, int y)
{
    int x0 = find(x);
    int y0 = find(y);
    father[y0] = x0;
}

//kruskal求解最小生成树
double kruskal()
{
    double total_weight = 0.0;
    init();
    int cnt = n * (n - 1) / 2;
    sort(e, e + cnt, cmp);
    int count = 0;

    for(int i = 0; i < cnt; ++ i)
    {
        int x = find(e[i].v);
        int y = find(e[i].u);
        if(x != y)
        {
            total_weight += e[i].w;
            //cout << e[i].w << endl;
            unit(x, y);
            count ++;
        }
        if(count == n - 1)
        {
            break;
        }
    }
    return total_weight;
}

int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);

    //ifstream cin("data.in");

    while(cin >> n)
    {
        for(int i = 0; i < n; ++ i)
        {
            //读取点坐标
            cin >> p[i].x >> p[i].y;
        }
        int cnt = 0;
        for(int i = 0; i < n; ++ i)
        {
            for(int j = i + 1; j < n; ++ j)
            {
                //转化为边
                e[cnt].v = i;
                e[cnt].u = j;
                double x = fabs(p[i].x - p[j].x);
                double y = fabs(p[i].y - p[j].y); 
                //cout << x << ", " << y << endl;
                e[cnt ++].w = sqrt(x * x + y * y);
            }
        }
        double total_weight = kruskal();
        //total_weight = prime()
        cout << setiosflags(ios::fixed) << setprecision(2) << total_weight << endl;
    }

    return 0;
} 
posted @ 2016-09-23 20:11  zq216991  阅读(109)  评论(0编辑  收藏  举报