hdoj 4006 The kth great number【优先队列】

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 8246    Accepted Submission(s): 3261


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

 

Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
 

 

Sample Output
1
2
3
 

题意:遇见I输入数据遇见Q输出数据中第k大的数

如1 2 3 4 5    3为第k(3)大的数据

其中I Q使用字符输入时容易出错建议使用字符串输入

  

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int main()
{
	int n,m,j,i,t,k;
	char a[5];
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		priority_queue<int,vector<int>,greater<int> >q;//按照从小到大的顺序定义的优先队列 
		while(n--)
		{
			getchar();
			scanf("%s",a);
			if(a[0]=='I')
			{
				scanf("%d",&k);
				q.push(k);
			}
			else
			{
				while(q.size()>m)
				q.pop();
				t=q.top();
				printf("%d\n",t);
			}
		}
	}
	return 0;
}

  

 

posted @ 2015-07-28 16:39  非我非非我  阅读(154)  评论(0编辑  收藏  举报