hdoj 1241 Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16542    Accepted Submission(s): 9500


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

 

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
 
Sample Output
0
1
2
2
 
简单的搜索题  和南阳的 水池数目差不多  只不过增加了 四个方向的搜索
/*
题意:给你一个规格为n*m的矩阵,由
字符'@'和'*'组成,问所有的@组成的区域
有多少块,(@组成的区域指向它的八个方向中其中一个方向
走依然是@) 
题解:先找到第一个@,然后向这个@的八个方向查找,将所有查找到的
@都替换为*(将找过的位置覆盖,避免重复查找),看最后调用了dfs函数
多少次,就有多少个区域 
*/

#include<stdio.h>   ///hdu1241 
#include<string.h>
#include<algorithm>
#define MAX 110
#define INF 0x3f3f3f
char map[MAX][MAX];
int n,m;
void dfs(int x,int y)
{
	int i,j;
	int move[8][2]={1,0,-1,0,0,1,0,-1,1,-1,1,1,-1,1,-1,-1};
	if(map[x][y]=='@'&&0<=x&&x<n&&0<=y&&y<m)
    {
        map[x][y]='*'; 
    	for(i=0;i<8;i++)//搜索八个方向 
    		dfs(x+move[i][0],y+move[i][1]);
    //可以用上边的辅助数组进行搜索 ,也可以直接按照下边注释的
	   //方法搜索,其原理相同 
//    	dfs(x-1,y);
//    	dfs(x+1,y);
//    	dfs(x,y-1);
//    	dfs(x,y+1);
//    	dfs(x-1,y-1);
//    	dfs(x-1,y+1);
//    	dfs(x+1,y-1);
//    	dfs(x+1,y+1);
    }
    return ;
}
int main()
{
	int j,i,t,k;
	while(scanf("%d%d",&n,&m),n|m)
	{
		for(i=0;i<n;i++)
		     scanf("%s",map[i]);
		
		int sum=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='@')
				{
					dfs(i,j);
					sum++;
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

  

  

posted @ 2015-06-14 22:29  非我非非我  阅读(290)  评论(0编辑  收藏  举报