hdoj 1102 Constructing Roads

并查集+最小生成树

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15844    Accepted Submission(s): 6028


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

 

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 

 

Sample Output
179
题目的意思是  首先输入一个数n  代表城市的数量(既测试数据中的3)接下来n行数,每行n个数,设i=n;j=n则每一行数的意义为第i个城市与第j个城市之间的距离(如 第一行0  990 692 意思为第一个城市与第一个城市之间距离为0,第一个城市与第二个城市之间距离为990,第一个城市与第三个城市之间距离为 692)
附上AC代码
kruskal算法
#include<stdio.h>
#include<algorithm>
int set[110];
using namespace std;
struct record
{
	int a;
	int b;
	int ju;
}s[200000];
int find(int fa)
{
	int ch=fa;
	int t;
	while(fa!=set[fa])
	fa=set[fa];
	while(ch!=fa)
	{
		t=set[ch];
		set[ch]=fa;
		ch=t;
	}
	return fa;
}
void mix(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	set[fx]=fy;
}
bool cmp(record a,record b)
{
	return a.ju<b.ju;
}
int main()
{
	int n,m,j,i,sum,ju1,village,k,q,v1,v2;
	while(scanf("%d",&village)!=EOF)
	{
	    k=0;m=0;
	    for(i=0;i<=village;i++)
	    {
		    set[i]=i;
	    }
	    for(i=1;i<=village;i++)   //注意此处应从1开始,因为没有0号城市 
	    {
		    for(j=1;j<=village;j++)   
		    {
			    scanf("%d",&ju1);
			    if(j>i)      //此循环计入了所有的两个城市组合之间的距离 
			    {             //以及对应城市编号 
				    s[k].a=i;    
				    s[k].b=j;
				    s[k].ju=ju1;
				    k++;
			    }
		    }
	    }
	    sort(s,s+k,cmp);
	    scanf("%d",&q);
	    for(i=0;i<q;i++)
	    {
		    scanf("%d%d",&v1,&v2);
		    mix(v1,v2);
	    }
	    sum=0;
	    for(i=0;i<k;i++)
	    {
		    if(find(s[i].a)!=find(s[i].b))
		    {
			    mix(s[i].a,s[i].b);
			    sum+=s[i].ju;
		    }
	    }
	    printf("%d\n",sum);
	}
	return 0;
}

  

 
posted @ 2015-05-01 12:15  非我非非我  阅读(139)  评论(0编辑  收藏  举报