代码改变世界

HDUOJ Number Sequence 题目1005

2017-06-29 19:28  tlnshuju  阅读(197)  评论(0编辑  收藏  举报


/*Number Sequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 127146    Accepted Submission(s): 30901
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
ZJCPC2004 
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1001 1003 1009 1012
*/
#include<stdio.h>
int main()
{
    int a,b,i;
    long long f[55],n;
    while(1)
    { scanf("%d %d %lld",&a,&b,&n);
        if(a==0&&b==0&&n==0)break;
        f[1]=f[2]=1;
        for(i=3;i<=49;i++)
         f[i]=(a*f[i-1]+b*f[i-2])%7;
        printf("%d\n",f[n%48]);
    }
    return 0;
}/*Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 127146 Accepted Submission(s): 30901
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
ZJCPC2004
Recommend
JGShining | We have carefully selected several similar problems for you: 1008 1001 1003 1009 1012
*/

又一道找规律题目
#include<stdio.h>
int main()
{
int a,b,i;
long long f[55],n;
while(1)
{ scanf("%d %d %lld",&a,&b,&n);
if(a==0&&b==0&&n==0)break;
f[1]=f[2]=1;
for(i=3;i<=49;i++)
f[i]=(a*f[i-1]+b*f[i-2])%7;
printf("%d\n",f[n%48]);
}
return 0;
}