NUC1474 Ants【水题】

Ants

时间限制: 1000ms 内存限制: 65535KB

通过次数: 1总提交次数: 1

问题描述
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
输入描述
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
输出描述
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
样例输入
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
样例输出
4 8
38 207
来源
Waterloo local 2004.09.19


问题分析:(略)

这个问题和《POJ1852 UVa10714 Ants【水题】》是同一个问题,代码直接用就AC了。

程序说明:参见参考链接。

参考链接:POJ1852 UVa10714 Ants【水题】

题记:程序做多了,不定哪天遇见似曾相识的。

AC的C++程序如下:

/* POJ1852 UVa10714 Ants */

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int t, l, n, pos, minans, maxans;

    scanf("%d", &t);;
    while(t--) {
        minans = 0;
        maxans = 0;

        scanf("%d%d", &l, &n);
        for(int i=1; i<=n; i++) {
            scanf("%d", &pos);

            minans = max(minans, min(pos, l - pos));

            maxans = max(maxans, max(pos, l - pos));
        }

        printf("%d %d\n", minans, maxans);
    }

    return 0;
}




posted on 2017-06-25 05:08  海岛Blog  阅读(111)  评论(0编辑  收藏  举报

导航